Bug 1026022

Summary: Unable to use wifi network after selecting "Minimal X Environment" (no iw, wpa_supplicant)
Product: [openSUSE] openSUSE Tumbleweed Reporter: João Pinto <lamego.pinto>
Component: InstallationAssignee: YaST Team <yast-internal>
Status: NEW --- QA Contact: Jiri Srain <jsrain>
Severity: Minor    
Priority: P5 - None CC: jreidinger, mfilka
Version: Current   
Target Milestone: ---   
Hardware: x86-64   
OS: SUSE Other   
URL: https://trello.com/c/q1CuUYd1
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description João Pinto 2017-02-18 08:59:47 UTC
I have installed with the "Minimal X Environment" option with the expectation to setup a different windows manager (cinammon) after installing the system. I only have Wifi connectivity, and the detection and system install from the Net worked fine with it.

After installing the system, I have attempted to configure the network from YaST, however I have found that wifi's core packages were missing: "iw", "wpa_supplicant". Using the Net install option, and with only wifi connectivity I was unable to setup the network. 

The wifi core packages should be installed when using the "Minimal X Environment" system.
Comment 1 Josef Reidinger 2017-02-20 08:51:27 UTC
Michal - does network proposal have such ability to mark required packages for working network?
Comment 2 Martin Vidner 2017-04-25 14:30:31 UTC
I'm not sure about the installation proposal, but the network code does declare the needed packages, including `iw` and `wpa_supplicant`:
https://github.com/yast/yast-network/blob/c4cb236531d704a466b5a285af75261fd64dfda5/src/modules/Lan.rb#L889