Bug 1029751 (CVE-2017-6436)

Summary: VUL-0: CVE-2017-6436: libplist: Integer overflow in parse_string_node
Product: [Novell Products] SUSE Security Incidents Reporter: Victor Pereira <vpereira>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Minor    
Priority: P3 - Medium CC: mgorse, smash_bz
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/181749/
Whiteboard: CVSSv3:RedHat:CVE-2017-6436:3.3:(AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L) CVSSv2:NVD:CVE-2017-6436:1.9:(AV:L/AC:M/Au:N/C:N/I:N/A:P) CVSSv3:NVD:CVE-2017-6436:5.0:(AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H)
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Victor Pereira 2017-03-16 16:00:54 UTC
rh#1432951

The parse_string_node function in bplist.c in libimobiledevice libplist 1.12
allows local users to cause a denial of service (memory allocation error) via a
crafted plist file.

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1432951
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-6436
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-6436
https://github.com/libimobiledevice/libplist/issues/94
https://github.com/libimobiledevice/libplist/commit/32ee5213fe64f1e10ec76c1ee861ee6f233120dd
Comment 2 Swamp Workflow Management 2017-08-17 10:15:05 UTC
SUSE-SU-2017:2201-1: An update that fixes 5 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1029638,1029639,1029706,1029707,1029751
CVE References: CVE-2017-6435,CVE-2017-6436,CVE-2017-6437,CVE-2017-6438,CVE-2017-6439
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP3 (src):    libplist-1.12-20.3.2
SUSE Linux Enterprise Workstation Extension 12-SP2 (src):    libplist-1.12-20.3.2
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    libplist-1.12-20.3.2
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    libplist-1.12-20.3.2
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    libplist-1.12-20.3.2
SUSE Linux Enterprise Server 12-SP3 (src):    libplist-1.12-20.3.2
SUSE Linux Enterprise Server 12-SP2 (src):    libplist-1.12-20.3.2
SUSE Linux Enterprise Desktop 12-SP3 (src):    libplist-1.12-20.3.2
SUSE Linux Enterprise Desktop 12-SP2 (src):    libplist-1.12-20.3.2
Comment 3 Swamp Workflow Management 2017-08-18 01:10:02 UTC
openSUSE-SU-2017:2208-1: An update that fixes 5 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1029638,1029639,1029706,1029707,1029751
CVE References: CVE-2017-6435,CVE-2017-6436,CVE-2017-6437,CVE-2017-6438,CVE-2017-6439
Sources used:
openSUSE Leap 42.3 (src):    libplist-1.12-11.1
openSUSE Leap 42.2 (src):    libplist-1.12-7.6.1
Comment 5 Marcus Meissner 2017-12-27 20:39:22 UTC
released