Bug 1078849

Summary: Certain system view nodes in Yast partitioner only displaying node label in main window area.
Product: [openSUSE] openSUSE Distribution Reporter: William Jackson <wtjack3>
Component: YaST2Assignee: Stefan Hundhammer <shundhammer>
Status: RESOLVED FIXED QA Contact: Jiri Srain <jsrain>
Severity: Normal    
Priority: P5 - None CC: ancor, per
Version: Leap 15.0   
Target Milestone: ---   
Hardware: Other   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---
Attachments: example
y2log

Description William Jackson 2018-02-01 17:20:15 UTC
Created attachment 758459 [details]
example

In the main window area of the Yast partitioner where the graphs, installation summary, settings options, etc. should be displayed, there is only centered text saying "devicegraph" or "summary" or "settings" instead.  This obviously deviates from the expected behavior, even when a particular node has no information to display, i. e. no installation summary because no changes have been made.  An example is attached.  This was a vanilla, rarely used (read: not up-to-date by a couple weeks), Tumbleweed installation up until I converted it to Leap 15 yesterday, so maybe it just missed a couple new libstorage-ng packages, like libstorage-ng-utils or one of the plugins for example.  However, I wasn't sure about this theory as the ones currently installed, libstorage-ng-lang libstorage-ng-ruby and libstorage-ng1, looked like they upgraded directly from libstorage7 and libstorage-ruby in the zypper logs (and this behavior was obviously not present with those packages).  The hard drive uses GPT in multi-boot with several other systems, and the root filesystem is xfs.
Comment 1 William Jackson 2018-02-02 06:48:57 UTC
Created attachment 758525 [details]
y2log
Comment 2 Ancor Gonzalez Sosa 2018-02-02 10:04:49 UTC
Your system is perfectly sane. The Expert Partitioner is being rewritten and those sections are indeed being worked as we speak. It will be finished by the Leap15 final release.

Meanwhile, you can follow the process at https://lizards.opensuse.org/author/yast-team/ We publish an status update there about the Partitioner rewrite (and other YaST stuff) every two weeks aprox.

I will assign the bug to myself and will let you know when all the sections are there (I estimate 4 weeks).
Comment 3 Per Jessen 2018-02-02 11:21:22 UTC
(In reply to Ancor Gonzalez Sosa from comment #2)
> Your system is perfectly sane. The Expert Partitioner is being rewritten and
> those sections are indeed being worked as we speak. It will be finished by
> the Leap15 final release.

That doesn't leave much time for testing?  I had hoped to try out NFS-root and iSCSI at least.
Comment 4 William Jackson 2018-02-02 19:57:12 UTC
(In reply to Ancor Gonzalez Sosa from comment #2)
> Your system is perfectly sane. The Expert Partitioner is being rewritten and
> those sections are indeed being worked as we speak. It will be finished by
> the Leap15 final release.
> 
> Meanwhile, you can follow the process at
> https://lizards.opensuse.org/author/yast-team/ We publish an status update
> there about the Partitioner rewrite (and other YaST stuff) every two weeks
> aprox.
> 
> I will assign the bug to myself and will let you know when all the sections
> are there (I estimate 4 weeks).

Awesome.  I'll continue testing as you guys work.  In reference to the "matching boot files" section of that page, I ran into that when trying to install the Leap 15 beta.  However, it downloaded the appropriate files and then took me back to the red error dialogue anyways.  This is why I just converted my Tumbleweed system.  Is that expected behavior at this point because you guys are still working on stuff, or would you like me to file a bug report for that too and get you some more information?
Comment 5 Stefan Hundhammer 2018-02-07 16:47:01 UTC
Disabled (commented out in the code) the empty pages for the time being:

- Crypt Files
- Device Mapper
- Unused Devices
- Mount Graph
- Settings (this one will be back soon with content)
Comment 6 Stefan Hundhammer 2018-02-07 17:00:51 UTC
Pull request: https://github.com/yast/yast-storage-ng/pull/512
Comment 7 Stefan Hundhammer 2018-02-07 17:42:03 UTC
The fix will be available with storage-ng-4.0.86.
Comment 8 Stefan Hundhammer 2018-02-08 10:48:29 UTC
Submit request to IBS SUSE:SLE-15:GA:

  https://build.suse.de/request/show/154197