Bug 1102165 (CVE-2018-14458)

Summary: VUL-0: CVE-2018-14458: libgig: There is a heap-based buffer overflow in pData[1] access in the function store32 in helper.h.
Product: [openSUSE] openSUSE Distribution Reporter: Karol Babioch <karol>
Component: SecurityAssignee: Edgar Aichinger <edogawa>
Status: NEW --- QA Contact: Security Team bot <security-team>
Severity: Minor    
Priority: P3 - Medium CC: wolfgang.frisch
Version: Leap 15.1   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/211238/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Karol Babioch 2018-07-23 07:36:22 UTC
CVE-2018-14458

An issue was discovered in libgig 4.1.0. There is a heap-based buffer overflow
in pData[1] access in the function store32 in helper.h.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-14458