Bug 1114495 (CVE-2018-18873)

Summary: VUL-1: CVE-2018-18873: ghostscript-library: A NULL pointer dereference in the function ras_putdatastd in ras/ras_enc.c.
Product: [Novell Products] SUSE Security Incidents Reporter: Robert Frohl <rfrohl>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Minor    
Priority: P4 - Low CC: abergmann, carlos.lopez, jsmeix, smash_bz
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/218463/
Whiteboard: CVSSv3:SUSE:CVE-2018-18873:3.3:(AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L)
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Robert Frohl 2018-11-02 14:11:05 UTC
CVE-2018-18873

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in
the function ras_putdatastd in ras/ras_enc.c.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-18873
http://people.canonical.com/~ubuntu-security/cve/2018/CVE-2018-18873.html
http://www.cvedetails.com/cve/CVE-2018-18873/
https://github.com/mdadams/jasper/issues/184
Comment 1 Robert Frohl 2018-11-02 14:15:10 UTC
jasper version of this vulnerability: bnc#1114498
Comment 2 Robert Frohl 2018-11-02 14:17:49 UTC
Hi Johannes,
my investigation suggests that the following codestream ships with an embedded version of jasper:
- SUSE:SLE-11-SP1:Update/ghostscript-library

SUSE:SLE-10-SP3:Update  is not affected.
Comment 6 Carlos López 2022-09-16 13:57:04 UTC
Done, closing.