Bug 1120515 (CVE-2018-5817)

Summary: VUL-1: CVE-2018-5817: libraw: DoS in unpacked_load_raw function in internal/dcraw_common.cpp
Product: [Novell Products] SUSE Security Incidents Reporter: Karol Babioch <karol>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Minor    
Priority: P4 - Low CC: smash_bz
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/221530/
Whiteboard: CVSSv3:RedHat:CVE-2018-5817:3.3:(AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L) CVSSv3:SUSE:CVE-2018-5817:3.3:(AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L)
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Karol Babioch 2019-01-02 14:50:42 UTC
LibRaw is vulnerable to a denial of service, caused by an error in the unpacked_load_raw function in internal/dcraw_common.cpp. By persuading a victim to open a specially-crafted file, a remote attacker could exploit this vulnerability to cause the application to enter into an infinite loop.


References:
https://www.flexera.com/company/secunia-research/advisories/SR-2018-27.html
https://bugzilla.redhat.com/show_bug.cgi?id=1661612
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-5817
http://people.canonical.com/~ubuntu-security/cve/2018/CVE-2018-5817.html
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5817
Comment 1 Petr Gajdos 2019-01-09 12:25:08 UTC
Will be submitted for 15,12/libraw.
Comment 2 Petr Gajdos 2019-01-09 12:29:52 UTC
I believe all fixed.
Comment 5 Swamp Workflow Management 2019-01-18 17:10:34 UTC
SUSE-SU-2019:0127-1: An update that fixes 6 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1120498,1120499,1120500,1120515,1120516,1120517
CVE References: CVE-2018-20363,CVE-2018-20364,CVE-2018-20365,CVE-2018-5817,CVE-2018-5818,CVE-2018-5819
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP4 (src):    libraw-0.15.4-30.1
SUSE Linux Enterprise Workstation Extension 12-SP3 (src):    libraw-0.15.4-30.1
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    libraw-0.15.4-30.1
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    libraw-0.15.4-30.1
SUSE Linux Enterprise Desktop 12-SP4 (src):    libraw-0.15.4-30.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    libraw-0.15.4-30.1
Comment 6 Swamp Workflow Management 2019-01-21 14:10:22 UTC
SUSE-SU-2019:0133-1: An update that fixes 7 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1120498,1120499,1120500,1120515,1120516,1120517,1120519
CVE References: CVE-2018-20337,CVE-2018-20363,CVE-2018-20364,CVE-2018-20365,CVE-2018-5817,CVE-2018-5818,CVE-2018-5819
Sources used:
SUSE Linux Enterprise Workstation Extension 15 (src):    libraw-0.18.9-3.8.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    libraw-0.18.9-3.8.1
Comment 7 Swamp Workflow Management 2019-01-29 14:21:05 UTC
openSUSE-SU-2019:0094-1: An update that fixes 7 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1120498,1120499,1120500,1120515,1120516,1120517,1120519
CVE References: CVE-2018-20337,CVE-2018-20363,CVE-2018-20364,CVE-2018-20365,CVE-2018-5817,CVE-2018-5818,CVE-2018-5819
Sources used:
openSUSE Leap 15.0 (src):    libraw-0.18.9-lp150.2.6.1
Comment 8 Marcus Meissner 2019-07-19 06:44:47 UTC
done
Comment 9 OBSbugzilla Bot 2021-09-27 16:40:31 UTC
This is an autogenerated message for OBS integration:
This bug (1120515) was mentioned in
https://build.opensuse.org/request/show/921823 Factory / libraw