Bug 1131055 (CVE-2019-0199)

Summary: VUL-0: CVE-2019-0199: tomcat: Apache Tomcat HTTP/2 DoS
Product: [Novell Products] SUSE Security Incidents Reporter: Marcus Meissner <meissner>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Major    
Priority: P3 - Medium CC: atoptsoglou, smash_bz
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/228297/
Whiteboard: CVSSv3:SUSE:CVE-2019-0199:7.5:(AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Marcus Meissner 2019-03-30 05:55:10 UTC
rh#1693325

A vulnerability was found in Apache Tomcat version from 9.0.0.M1 to 9.0.14 inclusive and 8.5.0 to 8.5.37 inclusive. The HTTP/2 implementation accepted streams with excessive numbers of SETTINGS frames and also permitted clients to keep streams open without reading/writing request/response data. By keeping streams open for requests that utilised the Servlet API's blocking I/O, clients were able to cause server-side threads to block eventually leading to thread exhaustion and a DoS.


References:
https://mail-archives.apache.org/mod_mbox/tomcat-announce/201903.mbox/browser
http://tomcat.apache.org/security-9.html
http://tomcat.apache.org/security-8.html

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1693325
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-0199
Comment 3 Swamp Workflow Management 2019-06-25 13:11:29 UTC
SUSE-SU-2019:1693-1: An update that solves two vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1111966,1131055,1136085
CVE References: CVE-2019-0199,CVE-2019-0221
Sources used:
SUSE Linux Enterprise Module for Web Scripting 15 (src):    tomcat-9.0.20-3.24.2
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    tomcat-9.0.20-3.24.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 4 Swamp Workflow Management 2019-06-30 22:12:49 UTC
openSUSE-SU-2019:1673-1: An update that solves two vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1111966,1131055,1136085
CVE References: CVE-2019-0199,CVE-2019-0221
Sources used:
openSUSE Leap 15.0 (src):    tomcat-9.0.20-lp150.2.19.1
Comment 9 Swamp Workflow Management 2019-07-17 16:18:05 UTC
SUSE-SU-2019:1866-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1131055,1136085,1139924
CVE References: CVE-2019-0199,CVE-2019-0221,CVE-2019-10072
Sources used:
SUSE Linux Enterprise Server 12-SP4 (src):    tomcat-9.0.21-3.13.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2019-07-18 22:13:51 UTC
SUSE-SU-2019:1895-1: An update that solves two vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1111966,1131055,1136085
CVE References: CVE-2019-0199,CVE-2019-0221
Sources used:
SUSE Linux Enterprise Module for Web Scripting 15-SP1 (src):    tomcat-9.0.21-4.5.5
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (src):    tomcat-9.0.21-4.5.5

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 12 Swamp Workflow Management 2019-07-25 13:17:31 UTC
openSUSE-SU-2019:1808-1: An update that solves two vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1111966,1131055,1136085
CVE References: CVE-2019-0199,CVE-2019-0221
Sources used:
openSUSE Leap 15.1 (src):    tomcat-9.0.21-lp151.3.3.1
Comment 14 Matei Albu 2020-06-10 08:47:43 UTC
(In reply to Alexandros Toptsoglou from comment #13)
> 12-SP2 is still tracked as affected

12-SP2 and 12-SP3 should not be affected by this. 
The CVE is about the HTTP/2 but in 12-SP2 (and 12-SP3) has Tomcat 8.0.53. In the 8.0.x series there's no support for HTTP/2. Support was added starting with 8.5.x and 9.0.x (SLE12-SP4 and later).
Comment 16 Marcus Meissner 2020-06-10 11:10:08 UTC
clsoing