Bug 1131245 (CVE-2019-0197)

Summary: VUL-0: CVE-2019-0197: apache2: mod_http2, possible crash on late upgrade
Product: [Novell Products] SUSE Security Incidents Reporter: Dan Čermák <dcermak>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P3 - Medium CC: dcermak, draht, kstreitova
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/228640/
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Dan Čermák 2019-04-02 08:52:25 UTC
Forward from of a bug report received via the OSS-security mailing list:

CVE-2019-0197: mod_http2, possible crash on late upgrade

Severity: Low

Vendor: The Apache Software Foundation

Versions Affected:
httpd 2.4.34 to 2.4.38

Description:
When HTTP/2 was enabled for a http: host or H2Upgrade was enabled for h2
on a https: host, an Upgrade request from http/1.1 to http/2 that was
not the first request on a connection could lead to a misconfiguration
and crash. Servers that never enabled the h2 protocol or only enabled it
for https: and did not set"H2Upgrade on" are unaffected by this issue.

Mitigation:
All httpd users deploying mod_http2 should upgrade to 2.4.39 or later.

Credit:
The issue was discovered by Stefan Eissing, greenbytes.de.

References:
https://httpd.apache.org/security/vulnerabilities_24.html
Comment 1 Petr Gajdos 2019-04-03 12:55:13 UTC
Submitted for 15/apache2 and 12sp2/apache2.

I believe all fixed.
Comment 3 Swamp Workflow Management 2019-04-04 22:10:37 UTC
SUSE-SU-2019:0873-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1131233,1131237,1131239,1131241,1131245
CVE References: CVE-2019-0196,CVE-2019-0197,CVE-2019-0211,CVE-2019-0217,CVE-2019-0220
Sources used:
SUSE Linux Enterprise Module for Server Applications 15 (src):    apache2-2.4.33-3.15.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    apache2-2.4.33-3.15.1

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 4 Swamp Workflow Management 2019-04-04 22:16:31 UTC
SUSE-SU-2019:0878-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1131233,1131237,1131239,1131241,1131245
CVE References: CVE-2019-0196,CVE-2019-0197,CVE-2019-0211,CVE-2019-0217,CVE-2019-0220
Sources used:
SUSE OpenStack Cloud 7 (src):    apache2-2.4.23-29.40.1
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    apache2-2.4.23-29.40.1
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    apache2-2.4.23-29.40.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    apache2-2.4.23-29.40.1
SUSE Linux Enterprise Server 12-SP4 (src):    apache2-2.4.23-29.40.1
SUSE Linux Enterprise Server 12-SP3 (src):    apache2-2.4.23-29.40.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    apache2-2.4.23-29.40.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    apache2-2.4.23-29.40.1
SUSE Enterprise Storage 4 (src):    apache2-2.4.23-29.40.1

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2019-04-11 13:09:39 UTC
openSUSE-SU-2019:1190-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1131233,1131237,1131239,1131241,1131245
CVE References: CVE-2019-0196,CVE-2019-0197,CVE-2019-0211,CVE-2019-0217,CVE-2019-0220
Sources used:
openSUSE Leap 42.3 (src):    apache2-2.4.23-45.1
Comment 6 Swamp Workflow Management 2019-04-16 13:10:34 UTC
openSUSE-SU-2019:1209-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1131233,1131237,1131239,1131241,1131245
CVE References: CVE-2019-0196,CVE-2019-0197,CVE-2019-0211,CVE-2019-0217,CVE-2019-0220
Sources used:
openSUSE Leap 15.0 (src):    apache2-2.4.33-lp150.2.17.1
Comment 7 Swamp Workflow Management 2019-04-23 19:10:28 UTC
openSUSE-SU-2019:1258-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1131233,1131237,1131239,1131241,1131245
CVE References: CVE-2019-0196,CVE-2019-0197,CVE-2019-0211,CVE-2019-0217,CVE-2019-0220
Sources used:
openSUSE Leap 42.3 (src):    apache2-2.4.23-49.1
Comment 8 Marcus Meissner 2019-07-18 07:06:30 UTC
done