Bug 1131427 (CVE-2019-3882)

Summary: VUL-0: CVE-2019-3882: kernel-source: denial of service vector through vfio DMA mappings
Product: [Novell Products] SUSE Security Incidents Reporter: Marcus Meissner <meissner>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P3 - Medium CC: bpetkov, dcermak, jroedel, smash_bz, tiwai
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/228701/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Marcus Meissner 2019-04-03 12:23:01 UTC
rh#1689426

A flaw was found in the Linux kernel vfio interface implementation that permits violation of the user's locked memory limit. If a device is bound to a vfio driver, such as vfio-pci, and the local attacker is administratively granted ownership of the device, it may cause a system memory exhaustion and thus a denial of service (DoS).

References:

https://seclists.org/oss-sec/2019/q2/6

A suggested fix:

https://lore.kernel.org/lkml/155414977872.12780.13728555131525362206.stgit@gimli.home/T/#u

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1689426
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-3882
Comment 1 Marcus Meissner 2019-04-03 12:23:59 UTC
not sure what versions are affected
Comment 2 Marcus Meissner 2019-04-03 12:57:16 UTC
*** Bug 1131416 has been marked as a duplicate of this bug. ***
Comment 4 Joerg Roedel 2019-04-05 14:00:52 UTC
(In reply to Marcus Meissner from comment #1)
> not sure what versions are affected

Most likely SLE12+

I'll take care of the backports.
Comment 5 Joerg Roedel 2019-04-12 11:26:42 UTC
Patch is upstream:

commit 492855939bdb59c6f947b0b5b44af9ad82b7e38c
Author: Alex Williamson <alex.williamson@redhat.com>
Date:   Wed Apr 3 12:36:21 2019 -0600

    vfio/type1: Limit DMA mappings per container
    
    Memory backed DMA mappings are accounted against a user's locked
    memory limit, including multiple mappings of the same memory.  This
    accounting bounds the number of such mappings that a user can create.
    However, DMA mappings that are not backed by memory, such as DMA
    mappings of device MMIO via mmaps, do not make use of page pinning
    and therefore do not count against the user's locked memory limit.
    These mappings still consume memory, but the memory is not well
    associated to the process for the purpose of oom killing a task.
    
    To add bounding on this use case, we introduce a limit to the total
    number of concurrent DMA mappings that a user is allowed to create.
    This limit is exposed as a tunable module option where the default
    value of 64K is expected to be well in excess of any reasonable use
    case (a large virtual machine configuration would typically only make
    use of tens of concurrent mappings).
    
    This fixes CVE-2019-3882.
    
    Reviewed-by: Eric Auger <eric.auger@redhat.com>
    Tested-by: Eric Auger <eric.auger@redhat.com>
    Reviewed-by: Peter Xu <peterx@redhat.com>
    Reviewed-by: Cornelia Huck <cohuck@redhat.com>
    Signed-off-by: Alex Williamson <alex.williamson@redhat.com>
Comment 6 Joerg Roedel 2019-04-12 13:23:04 UTC
Backported to

  - cve/linux-3.12
  - cve/linux-4.4
  - SLE15
  - stable

Older kernels do not have VFIO, so they are not affected.

My work is done here, assigning back.
Comment 16 Swamp Workflow Management 2019-05-14 19:21:14 UTC
This is an autogenerated message for OBS integration:
This bug (1131427) was mentioned in
https://build.opensuse.org/request/show/702938 15.0 / kernel-source
https://build.opensuse.org/request/show/702940 42.3 / kernel-source
Comment 17 Swamp Workflow Management 2019-05-14 22:24:24 UTC
SUSE-SU-2019:1242-1: An update that solves 9 vulnerabilities and has 165 fixes is now available.

Category: security (important)
Bug References: 1050549,1051510,1052904,1053043,1055117,1055121,1055186,1061840,1065600,1065729,1070872,1078216,1082555,1083647,1085535,1085536,1088804,1093777,1094120,1094244,1097583,1097584,1097585,1097586,1097587,1097588,1100132,1103186,1103259,1107937,1108193,1108937,1111331,1112128,1112178,1113399,1113722,1114279,1114542,1114638,1119086,1119680,1120318,1120902,1122767,1123105,1125342,1126221,1126356,1126704,1126740,1127175,1127371,1127372,1127374,1127378,1127445,1128415,1128544,1129273,1129276,1129770,1130130,1130154,1130195,1130335,1130336,1130337,1130338,1130425,1130427,1130518,1130527,1130567,1130579,1131062,1131107,1131167,1131168,1131169,1131170,1131171,1131172,1131173,1131174,1131175,1131176,1131177,1131178,1131179,1131180,1131290,1131326,1131335,1131336,1131416,1131427,1131442,1131467,1131574,1131587,1131659,1131673,1131847,1131848,1131851,1131900,1131934,1131935,1132083,1132219,1132226,1132227,1132365,1132368,1132369,1132370,1132372,1132373,1132384,1132397,1132402,1132403,1132404,1132405,1132407,1132411,1132412,1132413,1132414,1132426,1132527,1132531,1132555,1132558,1132561,1132562,1132563,1132564,1132570,1132571,1132572,1132589,1132618,1132681,1132726,1132828,1132943,1133005,1133094,1133095,1133115,1133149,1133486,1133529,1133584,1133667,1133668,1133672,1133674,1133675,1133698,1133702,1133731,1133769,1133772,1133774,1133778,1133779,1133780,1133825,1133850,1133851,1133852
CVE References: CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-16880,CVE-2019-11091,CVE-2019-3882,CVE-2019-9003,CVE-2019-9500,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Server 12-SP4 (src):    kernel-azure-4.12.14-6.12.1, kernel-source-azure-4.12.14-6.12.1, kernel-syms-azure-4.12.14-6.12.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 18 Swamp Workflow Management 2019-05-15 07:22:10 UTC
SUSE-SU-2019:1240-1: An update that solves 9 vulnerabilities and has 159 fixes is now available.

Category: security (important)
Bug References: 1050549,1051510,1052904,1053043,1055117,1055121,1061840,1065600,1065729,1070872,1078216,1082555,1083647,1085535,1085536,1088804,1093777,1094120,1094244,1097583,1097584,1097585,1097586,1097587,1097588,1100132,1103186,1103259,1107937,1111331,1112128,1112178,1113399,1113722,1114279,1114542,1114638,1119086,1119680,1120318,1120902,1122767,1123105,1125342,1126221,1126356,1126704,1126740,1127175,1127371,1127372,1127374,1127378,1127445,1128415,1128544,1129276,1129770,1130130,1130154,1130195,1130335,1130336,1130337,1130338,1130425,1130427,1130518,1130527,1130567,1131062,1131107,1131167,1131168,1131169,1131170,1131171,1131172,1131173,1131174,1131175,1131176,1131177,1131178,1131179,1131180,1131290,1131335,1131336,1131416,1131427,1131442,1131467,1131574,1131587,1131659,1131673,1131847,1131848,1131851,1131900,1131934,1131935,1132083,1132219,1132226,1132227,1132365,1132368,1132369,1132370,1132372,1132373,1132384,1132397,1132402,1132403,1132404,1132405,1132407,1132411,1132412,1132413,1132414,1132426,1132527,1132531,1132555,1132558,1132561,1132562,1132563,1132564,1132570,1132571,1132572,1132589,1132618,1132681,1132726,1132828,1132943,1133005,1133094,1133095,1133115,1133149,1133486,1133529,1133584,1133667,1133668,1133672,1133674,1133675,1133698,1133702,1133731,1133769,1133772,1133774,1133778,1133779,1133780,1133825,1133850,1133851,1133852
CVE References: CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-16880,CVE-2019-11091,CVE-2019-3882,CVE-2019-9003,CVE-2019-9500,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Module for Public Cloud 15 (src):    kernel-azure-4.12.14-5.27.1, kernel-source-azure-4.12.14-5.27.1, kernel-syms-azure-4.12.14-5.27.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 19 Swamp Workflow Management 2019-05-16 13:22:02 UTC
openSUSE-SU-2019:1404-1: An update that solves 12 vulnerabilities and has 182 fixes is now available.

Category: security (important)
Bug References: 1050549,1051510,1052904,1053043,1055117,1055121,1055186,1061840,1063638,1065600,1065729,1070872,1082555,1083647,1085535,1085536,1088804,1097583,1097584,1097585,1097586,1097587,1097588,1103186,1103259,1106011,1108193,1108838,1108937,1110946,1111331,1112063,1112128,1112178,1113722,1114279,1114427,1114542,1114638,1119680,1119843,1120318,1120902,1122767,1122776,1124839,1126221,1126704,1126740,1127175,1127371,1127372,1127374,1128052,1128415,1128544,1128979,1129138,1129273,1129497,1129770,1130195,1130425,1130527,1130567,1130579,1130972,1131107,1131167,1131168,1131169,1131170,1131171,1131172,1131173,1131174,1131175,1131176,1131177,1131178,1131179,1131180,1131290,1131326,1131335,1131336,1131416,1131427,1131442,1131451,1131467,1131488,1131574,1131587,1131659,1131673,1131847,1131848,1131851,1131900,1131934,1131935,1132044,1132083,1132219,1132226,1132227,1132365,1132368,1132369,1132370,1132372,1132373,1132384,1132397,1132402,1132403,1132404,1132405,1132407,1132411,1132412,1132413,1132414,1132426,1132527,1132531,1132555,1132558,1132561,1132562,1132563,1132564,1132570,1132571,1132572,1132589,1132618,1132681,1132726,1132828,1132943,1133005,1133094,1133095,1133115,1133149,1133176,1133188,1133486,1133529,1133584,1133667,1133668,1133672,1133674,1133675,1133698,1133702,1133731,1133769,1133772,1133774,1133778,1133779,1133780,1133825,1133850,1133851,1133852,1134160,1134162,1134199,1134200,1134201,1134202,1134203,1134204,1134205,1134354,1134393,1134459,1134460,1134461,1134537,1134651,1134760,1134810,1134813,1134848,1135006,1135007,1135008,1135100
CVE References: CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-16880,CVE-2019-11091,CVE-2019-11486,CVE-2019-11815,CVE-2019-11884,CVE-2019-3882,CVE-2019-9003,CVE-2019-9500,CVE-2019-9503
Sources used:
openSUSE Leap 15.0 (src):    kernel-debug-4.12.14-lp150.12.61.1, kernel-default-4.12.14-lp150.12.61.1, kernel-docs-4.12.14-lp150.12.61.1, kernel-kvmsmall-4.12.14-lp150.12.61.1, kernel-obs-build-4.12.14-lp150.12.61.1, kernel-obs-qa-4.12.14-lp150.12.61.1, kernel-source-4.12.14-lp150.12.61.1, kernel-syms-4.12.14-lp150.12.61.1, kernel-vanilla-4.12.14-lp150.12.61.1
Comment 20 Swamp Workflow Management 2019-05-17 19:15:13 UTC
SUSE-SU-2019:1287-1: An update that solves 16 vulnerabilities and has 19 fixes is now available.

Category: security (important)
Bug References: 1012382,1024908,1034113,1043485,1068032,1073311,1080157,1080533,1082632,1087231,1087659,1087906,1093158,1094268,1096748,1100152,1103186,1106913,1109772,1111331,1112178,1113399,1116841,1118338,1119019,1122822,1124832,1125580,1129279,1131416,1131427,1131587,1132673,1132828,1133188
CVE References: CVE-2016-8636,CVE-2017-17741,CVE-2017-18174,CVE-2018-1091,CVE-2018-1120,CVE-2018-1128,CVE-2018-1129,CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-19407,CVE-2019-11091,CVE-2019-11486,CVE-2019-3882,CVE-2019-8564,CVE-2019-9503
Sources used:
SUSE OpenStack Cloud 7 (src):    kernel-default-4.4.121-92.109.2, kernel-source-4.4.121-92.109.2, kernel-syms-4.4.121-92.109.2, kgraft-patch-SLE12-SP2_Update_29-1-3.5.2
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    kernel-default-4.4.121-92.109.2, kernel-source-4.4.121-92.109.2, kernel-syms-4.4.121-92.109.2, kgraft-patch-SLE12-SP2_Update_29-1-3.5.2
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    kernel-default-4.4.121-92.109.2, kernel-source-4.4.121-92.109.2, kernel-syms-4.4.121-92.109.2, kgraft-patch-SLE12-SP2_Update_29-1-3.5.2
SUSE Linux Enterprise Server 12-SP2-BCL (src):    kernel-default-4.4.121-92.109.2, kernel-source-4.4.121-92.109.2, kernel-syms-4.4.121-92.109.2
SUSE Linux Enterprise High Availability 12-SP2 (src):    kernel-default-4.4.121-92.109.2
SUSE Enterprise Storage 4 (src):    kernel-default-4.4.121-92.109.2, kernel-source-4.4.121-92.109.2, kernel-syms-4.4.121-92.109.2, kgraft-patch-SLE12-SP2_Update_29-1-3.5.2
OpenStack Cloud Magnum Orchestration 7 (src):    kernel-default-4.4.121-92.109.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 21 Swamp Workflow Management 2019-05-21 06:06:19 UTC
SUSE-SU-2019:1241-1: An update that solves 9 vulnerabilities and has 161 fixes is now available.

Category: security (important)
Bug References: 1050549,1051510,1052904,1053043,1055117,1055121,1055186,1061840,1065600,1065729,1070872,1082555,1083647,1085535,1085536,1088804,1094244,1097583,1097584,1097585,1097586,1097587,1097588,1100132,1103186,1103259,1108193,1108937,1111331,1112128,1112178,1113399,1113722,1114279,1114542,1114638,1119086,1119680,1120318,1120902,1122767,1123105,1125342,1126221,1126356,1126704,1126740,1127175,1127371,1127372,1127374,1127378,1127445,1128415,1128544,1129273,1129276,1129770,1130130,1130154,1130195,1130335,1130336,1130337,1130338,1130425,1130427,1130518,1130527,1130567,1130579,1131062,1131107,1131167,1131168,1131169,1131170,1131171,1131172,1131173,1131174,1131175,1131176,1131177,1131178,1131179,1131180,1131290,1131326,1131335,1131336,1131416,1131427,1131442,1131467,1131574,1131587,1131659,1131673,1131847,1131848,1131851,1131900,1131934,1131935,1132083,1132219,1132226,1132227,1132365,1132368,1132369,1132370,1132372,1132373,1132384,1132397,1132402,1132403,1132404,1132405,1132407,1132411,1132412,1132413,1132414,1132426,1132527,1132531,1132555,1132558,1132561,1132562,1132563,1132564,1132570,1132571,1132572,1132589,1132618,1132681,1132726,1132828,1132943,1133005,1133094,1133095,1133115,1133149,1133486,1133529,1133584,1133667,1133668,1133672,1133674,1133675,1133698,1133702,1133731,1133769,1133772,1133774,1133778,1133779,1133780,1133825,1133850,1133851,1133852
CVE References: CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-16880,CVE-2019-11091,CVE-2019-3882,CVE-2019-9003,CVE-2019-9500,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP4 (src):    kernel-default-4.12.14-95.16.1
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    kernel-docs-4.12.14-95.16.1, kernel-obs-build-4.12.14-95.16.1
SUSE Linux Enterprise Server 12-SP4 (src):    kernel-default-4.12.14-95.16.1, kernel-source-4.12.14-95.16.1, kernel-syms-4.12.14-95.16.1
SUSE Linux Enterprise Live Patching 12-SP4 (src):    kgraft-patch-SLE12-SP4_Update_4-1-6.3.1
SUSE Linux Enterprise High Availability 12-SP4 (src):    kernel-default-4.12.14-95.16.1
SUSE Linux Enterprise Desktop 12-SP4 (src):    kernel-default-4.12.14-95.16.1, kernel-source-4.12.14-95.16.1, kernel-syms-4.12.14-95.16.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 22 Swamp Workflow Management 2019-05-21 06:06:25 UTC
SUSE-SU-2019:1244-1: An update that solves 9 vulnerabilities and has 154 fixes is now available.

Category: security (important)
Bug References: 1050549,1051510,1052904,1053043,1055117,1055121,1061840,1065600,1065729,1070872,1082555,1083647,1085535,1085536,1088804,1094244,1097583,1097584,1097585,1097586,1097587,1097588,1100132,1103259,1111331,1112128,1112178,1113399,1113722,1114279,1114542,1114638,1119086,1119680,1120318,1120902,1122767,1123105,1125342,1126221,1126356,1126704,1126740,1127175,1127371,1127372,1127374,1127378,1127445,1128415,1128544,1129276,1129770,1130130,1130154,1130195,1130335,1130336,1130337,1130338,1130425,1130427,1130518,1130527,1130567,1131062,1131107,1131167,1131168,1131169,1131170,1131171,1131172,1131173,1131174,1131175,1131176,1131177,1131178,1131179,1131180,1131290,1131335,1131336,1131416,1131427,1131442,1131467,1131574,1131587,1131659,1131673,1131847,1131848,1131851,1131900,1131934,1131935,1132083,1132219,1132226,1132227,1132365,1132368,1132369,1132370,1132372,1132373,1132384,1132397,1132402,1132403,1132404,1132405,1132407,1132411,1132412,1132413,1132414,1132426,1132527,1132531,1132555,1132558,1132561,1132562,1132563,1132564,1132570,1132571,1132572,1132589,1132618,1132681,1132726,1132828,1132943,1133005,1133094,1133095,1133115,1133149,1133486,1133529,1133584,1133667,1133668,1133672,1133674,1133675,1133698,1133702,1133731,1133769,1133772,1133774,1133778,1133779,1133780,1133825,1133850,1133851,1133852
CVE References: CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-16880,CVE-2019-11091,CVE-2019-3882,CVE-2019-9003,CVE-2019-9500,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Workstation Extension 15 (src):    kernel-default-4.12.14-150.17.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    kernel-default-4.12.14-150.17.1, kernel-docs-4.12.14-150.17.1, kernel-obs-qa-4.12.14-150.17.1
SUSE Linux Enterprise Module for Live Patching 15 (src):    kernel-default-4.12.14-150.17.1, kernel-livepatch-SLE15_Update_10-1-1.3.1
SUSE Linux Enterprise Module for Legacy Software 15 (src):    kernel-default-4.12.14-150.17.1
SUSE Linux Enterprise Module for Development Tools 15 (src):    kernel-docs-4.12.14-150.17.1, kernel-obs-build-4.12.14-150.17.1, kernel-source-4.12.14-150.17.1, kernel-syms-4.12.14-150.17.1, kernel-vanilla-4.12.14-150.17.1
SUSE Linux Enterprise Module for Basesystem 15 (src):    kernel-default-4.12.14-150.17.1, kernel-source-4.12.14-150.17.1, kernel-zfcpdump-4.12.14-150.17.1
SUSE Linux Enterprise High Availability 15 (src):    kernel-default-4.12.14-150.17.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 23 Swamp Workflow Management 2019-05-21 06:07:11 UTC
SUSE-SU-2019:1241-1: An update that solves 9 vulnerabilities and has 161 fixes is now available.

Category: security (important)
Bug References: 1050549,1051510,1052904,1053043,1055117,1055121,1055186,1061840,1065600,1065729,1070872,1082555,1083647,1085535,1085536,1088804,1094244,1097583,1097584,1097585,1097586,1097587,1097588,1100132,1103186,1103259,1108193,1108937,1111331,1112128,1112178,1113399,1113722,1114279,1114542,1114638,1119086,1119680,1120318,1120902,1122767,1123105,1125342,1126221,1126356,1126704,1126740,1127175,1127371,1127372,1127374,1127378,1127445,1128415,1128544,1129273,1129276,1129770,1130130,1130154,1130195,1130335,1130336,1130337,1130338,1130425,1130427,1130518,1130527,1130567,1130579,1131062,1131107,1131167,1131168,1131169,1131170,1131171,1131172,1131173,1131174,1131175,1131176,1131177,1131178,1131179,1131180,1131290,1131326,1131335,1131336,1131416,1131427,1131442,1131467,1131574,1131587,1131659,1131673,1131847,1131848,1131851,1131900,1131934,1131935,1132083,1132219,1132226,1132227,1132365,1132368,1132369,1132370,1132372,1132373,1132384,1132397,1132402,1132403,1132404,1132405,1132407,1132411,1132412,1132413,1132414,1132426,1132527,1132531,1132555,1132558,1132561,1132562,1132563,1132564,1132570,1132571,1132572,1132589,1132618,1132681,1132726,1132828,1132943,1133005,1133094,1133095,1133115,1133149,1133486,1133529,1133584,1133667,1133668,1133672,1133674,1133675,1133698,1133702,1133731,1133769,1133772,1133774,1133778,1133779,1133780,1133825,1133850,1133851,1133852
CVE References: CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-16880,CVE-2019-11091,CVE-2019-3882,CVE-2019-9003,CVE-2019-9500,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Live Patching 12-SP4 (src):    kgraft-patch-SLE12-SP4_Update_4-1-6.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 24 Swamp Workflow Management 2019-05-21 06:07:11 UTC
SUSE-SU-2019:1289-1: An update that solves 33 vulnerabilities and has 13 fixes is now available.

Category: security (important)
Bug References: 1031240,1034862,1066674,1071021,1086535,1091171,1094825,1100001,1102517,1103097,1104475,1105025,1105296,1106913,1107829,1108498,1110768,1111331,1111516,1113751,1113769,1114648,1114920,1115007,1115038,1116345,1116841,1118152,1118319,1119714,1119946,1120743,1120758,1121621,1122015,1123161,1124010,1124728,1124732,1124735,1126890,1128166,1131416,1131427,1132828,1133188
CVE References: CVE-2016-10741,CVE-2017-1000407,CVE-2017-16533,CVE-2017-7273,CVE-2017-7472,CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-14633,CVE-2018-15572,CVE-2018-16884,CVE-2018-18281,CVE-2018-18386,CVE-2018-18690,CVE-2018-18710,CVE-2018-19407,CVE-2018-19824,CVE-2018-19985,CVE-2018-20169,CVE-2018-5391,CVE-2018-9516,CVE-2018-9568,CVE-2019-11091,CVE-2019-11486,CVE-2019-3459,CVE-2019-3460,CVE-2019-3882,CVE-2019-6974,CVE-2019-7221,CVE-2019-7222,CVE-2019-8564,CVE-2019-9213,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Server for SAP 12-SP1 (src):    kernel-default-3.12.74-60.64.110.1, kernel-source-3.12.74-60.64.110.1, kernel-syms-3.12.74-60.64.110.1, kernel-xen-3.12.74-60.64.110.1, lttng-modules-2.7.0-4.4.1
SUSE Linux Enterprise Server 12-SP1-LTSS (src):    kernel-default-3.12.74-60.64.110.1, kernel-source-3.12.74-60.64.110.1, kernel-syms-3.12.74-60.64.110.1, kernel-xen-3.12.74-60.64.110.1, lttng-modules-2.7.0-4.4.1
SUSE Linux Enterprise Module for Public Cloud 12 (src):    kernel-ec2-3.12.74-60.64.110.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 25 Swamp Workflow Management 2019-05-21 06:11:07 UTC
SUSE-SU-2019:1245-1: An update that solves 10 vulnerabilities and has 65 fixes is now available.

Category: security (important)
Bug References: 1012382,1020645,1020989,1031492,1047487,1051510,1053043,1062056,1063638,1066223,1070872,1085539,1087092,1094244,1096480,1096728,1097104,1100132,1105348,1106110,1106913,1106929,1111331,1112178,1113399,1114542,1114638,1114648,1114893,1118338,1118506,1119086,1120902,1122822,1125580,1126356,1127445,1129278,1129326,1129770,1130130,1130343,1130344,1130345,1130346,1130347,1130356,1130425,1130567,1130737,1131107,1131416,1131427,1131587,1131659,1131857,1131900,1131934,1131935,1131980,1132227,1132534,1132589,1132618,1132619,1132634,1132635,1132636,1132637,1132638,1132727,1132828,1133308,1133584,994770
CVE References: CVE-2018-1000204,CVE-2018-10853,CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-15594,CVE-2018-5814,CVE-2019-11091,CVE-2019-3882,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP3 (src):    kernel-default-4.4.178-94.91.2
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    kernel-docs-4.4.178-94.91.2, kernel-obs-build-4.4.178-94.91.1
SUSE Linux Enterprise Server 12-SP3 (src):    kernel-default-4.4.178-94.91.2, kernel-source-4.4.178-94.91.1, kernel-syms-4.4.178-94.91.1
SUSE Linux Enterprise High Availability 12-SP3 (src):    kernel-default-4.4.178-94.91.2
SUSE Linux Enterprise Desktop 12-SP3 (src):    kernel-default-4.4.178-94.91.2, kernel-source-4.4.178-94.91.1, kernel-syms-4.4.178-94.91.1
SUSE CaaS Platform ALL (src):    kernel-default-4.4.178-94.91.2
SUSE CaaS Platform 3.0 (src):    kernel-default-4.4.178-94.91.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 26 Swamp Workflow Management 2019-05-21 06:12:13 UTC
SUSE-SU-2019:1244-1: An update that solves 9 vulnerabilities and has 154 fixes is now available.

Category: security (important)
Bug References: 1050549,1051510,1052904,1053043,1055117,1055121,1061840,1065600,1065729,1070872,1082555,1083647,1085535,1085536,1088804,1094244,1097583,1097584,1097585,1097586,1097587,1097588,1100132,1103259,1111331,1112128,1112178,1113399,1113722,1114279,1114542,1114638,1119086,1119680,1120318,1120902,1122767,1123105,1125342,1126221,1126356,1126704,1126740,1127175,1127371,1127372,1127374,1127378,1127445,1128415,1128544,1129276,1129770,1130130,1130154,1130195,1130335,1130336,1130337,1130338,1130425,1130427,1130518,1130527,1130567,1131062,1131107,1131167,1131168,1131169,1131170,1131171,1131172,1131173,1131174,1131175,1131176,1131177,1131178,1131179,1131180,1131290,1131335,1131336,1131416,1131427,1131442,1131467,1131574,1131587,1131659,1131673,1131847,1131848,1131851,1131900,1131934,1131935,1132083,1132219,1132226,1132227,1132365,1132368,1132369,1132370,1132372,1132373,1132384,1132397,1132402,1132403,1132404,1132405,1132407,1132411,1132412,1132413,1132414,1132426,1132527,1132531,1132555,1132558,1132561,1132562,1132563,1132564,1132570,1132571,1132572,1132589,1132618,1132681,1132726,1132828,1132943,1133005,1133094,1133095,1133115,1133149,1133486,1133529,1133584,1133667,1133668,1133672,1133674,1133675,1133698,1133702,1133731,1133769,1133772,1133774,1133778,1133779,1133780,1133825,1133850,1133851,1133852
CVE References: CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-16880,CVE-2019-11091,CVE-2019-3882,CVE-2019-9003,CVE-2019-9500,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Module for Live Patching 15 (src):    kernel-default-4.12.14-150.17.1, kernel-livepatch-SLE15_Update_10-1-1.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 27 Swamp Workflow Management 2019-05-21 06:14:35 UTC
openSUSE-SU-2019:1407-1: An update that solves 14 vulnerabilities and has 90 fixes is now available.

Category: security (important)
Bug References: 1012382,1020645,1020989,1031492,1047487,1051510,1053043,1062056,1063638,1064388,1066223,1070872,1085539,1087092,1094244,1096480,1096728,1097104,1100132,1103186,1105348,1106110,1106913,1106929,1108293,1110785,1110946,1111331,1112063,1112178,1113399,1114542,1114638,1114648,1114893,1116803,1118338,1118506,1119086,1119974,1120902,1122776,1122822,1125580,1126040,1126356,1127445,1129138,1129278,1129326,1129770,1130130,1130343,1130344,1130345,1130346,1130347,1130356,1130425,1130567,1130737,1130972,1131107,1131416,1131427,1131488,1131587,1131659,1131857,1131900,1131934,1131935,1131980,1132212,1132227,1132534,1132589,1132618,1132619,1132634,1132635,1132636,1132637,1132638,1132727,1132828,1133188,1133308,1133584,1134160,1134162,1134537,1134564,1134565,1134566,1134651,1134760,1134848,1135013,1135014,1135015,1135100,843419,994770
CVE References: CVE-2018-1000204,CVE-2018-10853,CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-15594,CVE-2018-17972,CVE-2018-5814,CVE-2019-11091,CVE-2019-11486,CVE-2019-11815,CVE-2019-11884,CVE-2019-3882,CVE-2019-9503
Sources used:
openSUSE Leap 42.3 (src):    kernel-debug-4.4.179-99.1, kernel-default-4.4.179-99.1, kernel-docs-4.4.179-99.1, kernel-obs-build-4.4.179-99.1, kernel-obs-qa-4.4.179-99.1, kernel-source-4.4.179-99.1, kernel-syms-4.4.179-99.1, kernel-vanilla-4.4.179-99.1
Comment 31 Swamp Workflow Management 2019-06-18 19:27:19 UTC
SUSE-SU-2019:1550-1: An update that solves 28 vulnerabilities and has 318 fixes is now available.

Category: security (important)
Bug References: 1012382,1050242,1050549,1051510,1052904,1053043,1055117,1055121,1055186,1056787,1058115,1061840,1063638,1064802,1065600,1065729,1066129,1068546,1070872,1071995,1075020,1082387,1082555,1083647,1085535,1085536,1086657,1088804,1093389,1097583,1097584,1097585,1097586,1097587,1097588,1099658,1103186,1103259,1103992,1104353,1104427,1106011,1106284,1108193,1108838,1108937,1110946,1111331,1111666,1111696,1112063,1112128,1112178,1113722,1113956,1114279,1114427,1114542,1114638,1115688,1117114,1117158,1117561,1118139,1119680,1119843,1120091,1120318,1120423,1120566,1120843,1120902,1122767,1122776,1123454,1123663,1124503,1124839,1126206,1126356,1126704,1127175,1127371,1127374,1127616,1128052,1128415,1128544,1128904,1128971,1128979,1129138,1129273,1129497,1129693,1129770,1129845,1130195,1130425,1130527,1130567,1130579,1130699,1130937,1130972,1131326,1131427,1131438,1131451,1131467,1131488,1131530,1131565,1131574,1131587,1131659,1131673,1131847,1131848,1131851,1131900,1131934,1131935,1132044,1132219,1132226,1132227,1132365,1132368,1132369,1132370,1132372,1132373,1132384,1132397,1132402,1132403,1132404,1132405,1132407,1132411,1132412,1132413,1132414,1132426,1132527,1132531,1132555,1132558,1132561,1132562,1132563,1132564,1132570,1132571,1132572,1132589,1132618,1132673,1132681,1132726,1132828,1132894,1132943,1132982,1133005,1133016,1133094,1133095,1133115,1133149,1133176,1133188,1133190,1133320,1133486,1133529,1133547,1133584,1133593,1133612,1133616,1133667,1133668,1133672,1133674,1133675,1133698,1133702,1133731,1133769,1133772,1133774,1133778,1133779,1133780,1133825,1133850,1133851,1133852,1133897,1134090,1134160,1134162,1134199,1134200,1134201,1134202,1134203,1134204,1134205,1134223,1134354,1134393,1134397,1134459,1134460,1134461,1134597,1134600,1134607,1134618,1134651,1134671,1134760,1134806,1134810,1134813,1134848,1134936,1134945,1134946,1134947,1134948,1134949,1134950,1134951,1134952,1134953,1134972,1134974,1134975,1134980,1134981,1134983,1134987,1134989,1134990,1134994,1134995,1134998,1134999,1135006,1135007,1135008,1135018,1135021,1135024,1135026,1135027,1135028,1135029,1135031,1135033,1135034,1135035,1135036,1135037,1135038,1135039,1135041,1135042,1135044,1135045,1135046,1135047,1135049,1135051,1135052,1135053,1135055,1135056,1135058,1135100,1135120,1135278,1135281,1135309,1135312,1135314,1135315,1135316,1135320,1135323,1135330,1135492,1135542,1135556,1135603,1135642,1135661,1135758,1136188,1136206,1136215,1136345,1136347,1136348,1136353,1136424,1136428,1136430,1136432,1136434,1136435,1136438,1136439,1136456,1136460,1136461,1136469,1136477,1136478,1136498,1136573,1136586,1136881,1136935,1136990,1137151,1137152,1137153,1137162,1137201,1137224,1137232,1137233,1137236,1137372,1137429,1137444,1137586,1137739,1137752,1138291,1138293
CVE References: CVE-2017-5753,CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-16880,CVE-2018-7191,CVE-2019-10124,CVE-2019-11085,CVE-2019-11091,CVE-2019-11477,CVE-2019-11478,CVE-2019-11479,CVE-2019-11486,CVE-2019-11487,CVE-2019-11811,CVE-2019-11815,CVE-2019-11833,CVE-2019-11884,CVE-2019-12382,CVE-2019-12818,CVE-2019-12819,CVE-2019-3846,CVE-2019-3882,CVE-2019-5489,CVE-2019-8564,CVE-2019-9003,CVE-2019-9500,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Module for Live Patching 15-SP1 (src):    kernel-default-4.12.14-197.4.1, kernel-livepatch-SLE15-SP1_Update_1-1-3.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 32 Swamp Workflow Management 2019-06-18 22:43:03 UTC
SUSE-SU-2019:1550-1: An update that solves 28 vulnerabilities and has 318 fixes is now available.

Category: security (important)
Bug References: 1012382,1050242,1050549,1051510,1052904,1053043,1055117,1055121,1055186,1056787,1058115,1061840,1063638,1064802,1065600,1065729,1066129,1068546,1070872,1071995,1075020,1082387,1082555,1083647,1085535,1085536,1086657,1088804,1093389,1097583,1097584,1097585,1097586,1097587,1097588,1099658,1103186,1103259,1103992,1104353,1104427,1106011,1106284,1108193,1108838,1108937,1110946,1111331,1111666,1111696,1112063,1112128,1112178,1113722,1113956,1114279,1114427,1114542,1114638,1115688,1117114,1117158,1117561,1118139,1119680,1119843,1120091,1120318,1120423,1120566,1120843,1120902,1122767,1122776,1123454,1123663,1124503,1124839,1126206,1126356,1126704,1127175,1127371,1127374,1127616,1128052,1128415,1128544,1128904,1128971,1128979,1129138,1129273,1129497,1129693,1129770,1129845,1130195,1130425,1130527,1130567,1130579,1130699,1130937,1130972,1131326,1131427,1131438,1131451,1131467,1131488,1131530,1131565,1131574,1131587,1131659,1131673,1131847,1131848,1131851,1131900,1131934,1131935,1132044,1132219,1132226,1132227,1132365,1132368,1132369,1132370,1132372,1132373,1132384,1132397,1132402,1132403,1132404,1132405,1132407,1132411,1132412,1132413,1132414,1132426,1132527,1132531,1132555,1132558,1132561,1132562,1132563,1132564,1132570,1132571,1132572,1132589,1132618,1132673,1132681,1132726,1132828,1132894,1132943,1132982,1133005,1133016,1133094,1133095,1133115,1133149,1133176,1133188,1133190,1133320,1133486,1133529,1133547,1133584,1133593,1133612,1133616,1133667,1133668,1133672,1133674,1133675,1133698,1133702,1133731,1133769,1133772,1133774,1133778,1133779,1133780,1133825,1133850,1133851,1133852,1133897,1134090,1134160,1134162,1134199,1134200,1134201,1134202,1134203,1134204,1134205,1134223,1134354,1134393,1134397,1134459,1134460,1134461,1134597,1134600,1134607,1134618,1134651,1134671,1134760,1134806,1134810,1134813,1134848,1134936,1134945,1134946,1134947,1134948,1134949,1134950,1134951,1134952,1134953,1134972,1134974,1134975,1134980,1134981,1134983,1134987,1134989,1134990,1134994,1134995,1134998,1134999,1135006,1135007,1135008,1135018,1135021,1135024,1135026,1135027,1135028,1135029,1135031,1135033,1135034,1135035,1135036,1135037,1135038,1135039,1135041,1135042,1135044,1135045,1135046,1135047,1135049,1135051,1135052,1135053,1135055,1135056,1135058,1135100,1135120,1135278,1135281,1135309,1135312,1135314,1135315,1135316,1135320,1135323,1135330,1135492,1135542,1135556,1135603,1135642,1135661,1135758,1136188,1136206,1136215,1136345,1136347,1136348,1136353,1136424,1136428,1136430,1136432,1136434,1136435,1136438,1136439,1136456,1136460,1136461,1136469,1136477,1136478,1136498,1136573,1136586,1136881,1136935,1136990,1137151,1137152,1137153,1137162,1137201,1137224,1137232,1137233,1137236,1137372,1137429,1137444,1137586,1137739,1137752,1138291,1138293
CVE References: CVE-2017-5753,CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-16880,CVE-2018-7191,CVE-2019-10124,CVE-2019-11085,CVE-2019-11091,CVE-2019-11477,CVE-2019-11478,CVE-2019-11479,CVE-2019-11486,CVE-2019-11487,CVE-2019-11811,CVE-2019-11815,CVE-2019-11833,CVE-2019-11884,CVE-2019-12382,CVE-2019-12818,CVE-2019-12819,CVE-2019-3846,CVE-2019-3882,CVE-2019-5489,CVE-2019-8564,CVE-2019-9003,CVE-2019-9500,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Workstation Extension 15-SP1 (src):    kernel-default-4.12.14-197.4.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (src):    dtb-aarch64-4.12.14-197.4.1, kernel-debug-4.12.14-197.4.1, kernel-default-4.12.14-197.4.1, kernel-docs-4.12.14-197.4.1, kernel-kvmsmall-4.12.14-197.4.1, kernel-obs-qa-4.12.14-197.4.1, kernel-source-4.12.14-197.4.1, kernel-vanilla-4.12.14-197.4.1, kernel-zfcpdump-4.12.14-197.4.1
SUSE Linux Enterprise Module for Live Patching 15-SP1 (src):    kernel-default-4.12.14-197.4.1, kernel-livepatch-SLE15-SP1_Update_1-1-3.3.1
SUSE Linux Enterprise Module for Legacy Software 15-SP1 (src):    kernel-default-4.12.14-197.4.1
SUSE Linux Enterprise Module for Development Tools 15-SP1 (src):    kernel-docs-4.12.14-197.4.1, kernel-obs-build-4.12.14-197.4.1, kernel-source-4.12.14-197.4.1, kernel-syms-4.12.14-197.4.1
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    kernel-default-4.12.14-197.4.1, kernel-source-4.12.14-197.4.1, kernel-zfcpdump-4.12.14-197.4.1
SUSE Linux Enterprise High Availability 15-SP1 (src):    kernel-default-4.12.14-197.4.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 33 Marcus Meissner 2019-07-15 06:26:53 UTC
done
Comment 37 Swamp Workflow Management 2019-09-23 13:36:01 UTC
SUSE-SU-2019:2430-1: An update that solves 45 vulnerabilities and has 474 fixes is now available.

Category: security (important)
Bug References: 1050242,1050549,1051510,1052904,1053043,1055117,1055121,1055186,1056787,1058115,1061840,1064802,1065600,1065729,1066129,1070872,1071995,1075020,1082387,1082555,1083647,1083710,1085535,1085536,1088047,1088804,1093389,1094555,1096003,1098633,1099658,1102247,1103186,1103259,1103990,1103991,1103992,1104745,1106011,1106284,1106383,1106751,1108193,1108838,1108937,1109837,1110946,1111331,1111666,1111696,1112063,1112128,1112178,1112374,1113722,1113956,1114279,1114427,1114542,1114638,1114685,1115688,1117114,1117158,1117561,1118139,1119113,1119222,1119532,1119680,1120091,1120318,1120423,1120566,1120843,1120902,1122767,1122776,1123080,1123454,1123663,1124503,1124839,1125703,1126206,1126356,1126704,1127034,1127175,1127315,1127371,1127374,1127611,1127616,1128052,1128415,1128432,1128544,1128902,1128904,1128971,1128979,1129138,1129273,1129693,1129770,1129845,1130195,1130425,1130527,1130567,1130579,1130699,1130836,1130937,1130972,1131326,1131427,1131438,1131451,1131467,1131488,1131530,1131565,1131574,1131587,1131645,1131659,1131673,1131847,1131848,1131851,1131900,1131934,1131935,1132044,1132219,1132226,1132227,1132365,1132368,1132369,1132370,1132372,1132373,1132384,1132390,1132397,1132402,1132403,1132404,1132405,1132407,1132411,1132412,1132413,1132414,1132426,1132527,1132531,1132555,1132558,1132561,1132562,1132563,1132564,1132570,1132571,1132572,1132589,1132618,1132673,1132681,1132726,1132828,1132894,1132943,1132982,1133005,1133016,1133021,1133094,1133095,1133115,1133149,1133176,1133188,1133190,1133311,1133320,1133401,1133486,1133529,1133547,1133584,1133593,1133612,1133616,1133667,1133668,1133672,1133674,1133675,1133698,1133702,1133731,1133738,1133769,1133772,1133774,1133778,1133779,1133780,1133825,1133850,1133851,1133852,1133897,1134090,1134097,1134160,1134162,1134199,1134200,1134201,1134202,1134203,1134204,1134205,1134223,1134303,1134354,1134390,1134393,1134395,1134397,1134399,1134459,1134460,1134461,1134597,1134600,1134607,1134618,1134651,1134671,1134730,1134738,1134743,1134760,1134806,1134810,1134813,1134848,1134936,1134945,1134946,1134947,1134948,1134949,1134950,1134951,1134952,1134953,1134972,1134974,1134975,1134980,1134981,1134983,1134987,1134989,1134990,1134994,1134995,1134998,1134999,1135006,1135007,1135008,1135018,1135021,1135024,1135026,1135027,1135028,1135029,1135031,1135033,1135034,1135035,1135036,1135037,1135038,1135039,1135041,1135042,1135044,1135045,1135046,1135047,1135049,1135051,1135052,1135053,1135055,1135056,1135058,1135100,1135120,1135153,1135278,1135281,1135296,1135309,1135312,1135314,1135315,1135316,1135320,1135323,1135330,1135335,1135492,1135542,1135556,1135603,1135642,1135661,1135758,1135897,1136156,1136157,1136161,1136188,1136206,1136215,1136217,1136264,1136271,1136333,1136342,1136343,1136345,1136347,1136348,1136353,1136424,1136428,1136430,1136432,1136434,1136435,1136438,1136439,1136456,1136460,1136461,1136462,1136467,1136469,1136477,1136478,1136498,1136573,1136586,1136598,1136881,1136922,1136935,1136978,1136990,1137103,1137151,1137152,1137153,1137162,1137194,1137201,1137224,1137232,1137233,1137236,1137366,1137372,1137429,1137444,1137458,1137534,1137535,1137584,1137586,1137609,1137625,1137728,1137739,1137752,1137811,1137827,1137884,1137985,1137995,1137996,1137998,1137999,1138000,1138002,1138003,1138005,1138006,1138007,1138008,1138009,1138010,1138011,1138012,1138013,1138014,1138015,1138016,1138017,1138018,1138019,1138263,1138291,1138293,1138336,1138374,1138375,1138589,1138681,1138719,1138732,1138874,1138879,1139358,1139619,1139712,1139751,1139771,1139865,1140133,1140139,1140228,1140322,1140328,1140405,1140424,1140428,1140454,1140463,1140559,1140575,1140577,1140637,1140652,1140658,1140676,1140715,1140719,1140726,1140727,1140728,1140814,1140887,1140888,1140889,1140891,1140893,1140903,1140945,1140948,1140954,1140955,1140956,1140957,1140958,1140959,1140960,1140961,1140962,1140964,1140971,1140972,1140992,1141312,1141401,1141402,1141452,1141453,1141454,1141478,1141558,1142023,1142052,1142083,1142112,1142115,1142119,1142220,1142221,1142254,1142350,1142351,1142354,1142359,1142450,1142623,1142673,1142701,1142868,1143003,1143045,1143105,1143185,1143189,1143191,1143209,1143507
CVE References: CVE-2017-5753,CVE-2018-12126,CVE-2018-12127,CVE-2018-12130,CVE-2018-16871,CVE-2018-16880,CVE-2018-20836,CVE-2018-20855,CVE-2018-7191,CVE-2019-10124,CVE-2019-10638,CVE-2019-10639,CVE-2019-11085,CVE-2019-11091,CVE-2019-1125,CVE-2019-11477,CVE-2019-11478,CVE-2019-11479,CVE-2019-11486,CVE-2019-11487,CVE-2019-11599,CVE-2019-11810,CVE-2019-11811,CVE-2019-11815,CVE-2019-11833,CVE-2019-11884,CVE-2019-12380,CVE-2019-12382,CVE-2019-12456,CVE-2019-12614,CVE-2019-12817,CVE-2019-12818,CVE-2019-12819,CVE-2019-13233,CVE-2019-13631,CVE-2019-13648,CVE-2019-14283,CVE-2019-14284,CVE-2019-3846,CVE-2019-3882,CVE-2019-5489,CVE-2019-8564,CVE-2019-9003,CVE-2019-9500,CVE-2019-9503
Sources used:
SUSE Linux Enterprise Module for Realtime 15-SP1 (src):    kernel-rt-4.12.14-14.8.1, kernel-rt_debug-4.12.14-14.8.1, kernel-source-rt-4.12.14-14.8.1, kernel-syms-rt-4.12.14-14.8.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (src):    kernel-rt-4.12.14-14.8.1, kernel-rt_debug-4.12.14-14.8.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.