Bugzilla – Full Text Bug Listing
|Summary:||VUL-0: CVE-2019-5429: filezilla: Privileges escalation via malicious 'fzsftp' binary in home directory.|
|Product:||[openSUSE] openSUSE Distribution||Reporter:||Marcus Meissner <meissner>|
|Component:||Other||Assignee:||Eric Schirra <ecsos>|
|Status:||RESOLVED WORKSFORME||QA Contact:||Security Team bot <security-team>|
|Priority:||P3 - Medium||CC:||Andreas.Stieger, atoptsoglou|
|Found By:||Security Response Team||Services Priority:|
|Marketing QA Status:||---||IT Deployment:||---|
|Bug Depends on:||1130088|
Description Marcus Meissner 2019-04-30 10:04:46 UTC
rh#1704602 Untrusted search path in FileZilla before 3.41.0-rc1 allows an attacker to gain privileges via a malicious 'fzsftp' binary in the user's home directory. External References: https://www.tenable.com/security/research/tra-2019-14 References: https://bugzilla.redhat.com/show_bug.cgi?id=1704602 http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-5429 http://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-5429.html http://www.cvedetails.com/cve/CVE-2019-5429/ http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-5429 https://svn.filezilla-project.org/filezilla?view=revision&revision=9112 https://www.tenable.com/security/research/tra-2019-14
Comment 1 Eric Schirra 2019-04-30 17:05:58 UTC
In network repo and facory are 3.41.2. But 3.41.2 can not build for Leap 42.3, 15.0 and 15.1, because wxwidgets is to old. And nettle and gnutls in 42.3 too. So what can i do?
Comment 2 Andreas Stieger 2019-05-02 14:15:29 UTC
Instead of doing the version update, apply this patch only: https://svn.filezilla-project.org/filezilla?revision=9097&view=revision
Comment 3 Eric Schirra 2019-05-20 07:02:29 UTC
I cannot see that this files patch the security issue. So i have now update libfilzilla and filezilla to 3.42.1 in repo network. When wxWidgets will update to 3.0.4 then filezilla 3.42.1 will build for 15.0, 15.1. Leap 42.3 is definitive to old. So. Please update wxWidgets. See also https://bugzilla.opensuse.org/show_bug.cgi?id=1130088
Comment 4 Tomáš Chvátal 2019-07-11 11:41:47 UTC
This is automated batch bugzilla cleanup. The openSUSE 42.3 changed to end-of-life (EOL ) status. As such it is no longer maintained, which means that it will not receive any further security or bug fix updates. As a result we are closing this bug. If you can reproduce this bug against a currently maintained version of openSUSE (At this moment openSUSE Leap 15.1, 15.0 and Tumbleweed) please feel free to reopen this bug against that version (!you must update the "Version" component in the bug fields, do not just reopen please), or alternatively create a new ticket. Thank you for reporting this bug and we are sorry it could not be fixed during the lifetime of the release.  https://en.opensuse.org/Lifetime
Comment 5 Marcus Meissner 2019-07-11 12:12:41 UTC
15.0 still affected
Comment 6 Eric Schirra 2019-11-04 17:15:36 UTC
(In reply to Marcus Meissner from comment #5) > 15.0 still affected wxwidgets is still to old. And still I cannot see that this files patch the security issue. Please update wxwidgets.
Comment 7 Eric Schirra 2020-03-29 18:42:37 UTC
15.0 is end of lifetime.
Comment 8 Alexandros Toptsoglou 2020-04-06 09:30:57 UTC
15.1 still affected
Comment 9 Eric Schirra 2020-04-06 09:45:30 UTC
Do you read my comment: wxwidgets is still to old. filezilla needs 3.0.4 In Leap 15.1 and 15.2 is only 3.0.3 And openSUSE will not accepted my request for update of wxwidgets. It will be an minor-minor update! And so i have no changes to update. Use filezilla from devel or from my repo and security issue is gone.