Bug 1143032 (CVE-2019-14274)

Summary: VUL-0: CVE-2019-14274: mcpp: heap-based buffer overflow in the do_msg() function in support.c
Product: [openSUSE] openSUSE Distribution Reporter: Alexandros Toptsoglou <atoptsoglou>
Component: SecurityAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P3 - Medium    
Version: Leap 15.1   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/238074/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Alexandros Toptsoglou 2019-07-26 12:04:08 UTC
CVE-2019-14274

MCPP 2.7.2 has a heap-based buffer overflow in the do_msg() function in
support.c.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-14274
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14274
https://sourceforge.net/p/mcpp/bugs/13/
Comment 1 Dirk Mueller 2020-03-18 17:31:48 UTC
submitted to Tumbleweed and as an update to Leap 15.1
Comment 2 Swamp Workflow Management 2020-03-18 18:10:06 UTC
This is an autogenerated message for OBS integration:
This bug (1143032) was mentioned in
https://build.opensuse.org/request/show/786229 Factory / mcpp
https://build.opensuse.org/request/show/786230 15.1 / mcpp
Comment 3 Swamp Workflow Management 2020-03-25 14:13:23 UTC
openSUSE-SU-2020:0382-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1143032
CVE References: CVE-2019-14274
Sources used:
openSUSE Leap 15.1 (src):    mcpp-2.7.2-lp151.3.3.1
Comment 4 Swamp Workflow Management 2020-03-27 11:17:53 UTC
openSUSE-SU-2020:0391-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1143032
CVE References: CVE-2019-14274
Sources used:
openSUSE Backports SLE-15-SP1 (src):    mcpp-2.7.2-bp151.4.3.1
Comment 5 Alexandros Toptsoglou 2020-05-04 12:14:37 UTC
Done