Bug 1159825 (CVE-2019-20010)

Summary: VUL-1: CVE-2019-20010: libredwg: use-after-free in resolve_objectref_vector in decode.c
Product: [openSUSE] openSUSE Distribution Reporter: Alexandros Toptsoglou <atoptsoglou>
Component: SecurityAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P4 - Low    
Version: Leap 15.1   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/249844/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Alexandros Toptsoglou 2019-12-27 08:40:25 UTC
CVE-2019-20010

An issue was discovered in GNU LibreDWG 0.92. There is a use-after-free in
resolve_objectref_vector in decode.c.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-20010
https://github.com/LibreDWG/libredwg/issues/176#issuecomment-568643383
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-20010
https://github.com/LibreDWG/libredwg/issues/176
Comment 1 Swamp Workflow Management 2019-12-29 23:41:09 UTC
This is an autogenerated message for OBS integration:
This bug (1159825) was mentioned in
https://build.opensuse.org/request/show/759939 Factory / libredwg
https://build.opensuse.org/request/show/759940 15.1 / libredwg
Comment 2 Swamp Workflow Management 2020-01-09 14:40:48 UTC
This is an autogenerated message for OBS integration:
This bug (1159825) was mentioned in
https://build.opensuse.org/request/show/762219 15.1 / libredwg
Comment 3 Swamp Workflow Management 2020-01-17 17:12:20 UTC
openSUSE-SU-2020:0068-1: An update that solves 17 vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1129868,1129869,1129870,1129873,1129874,1129875,1129876,1129878,1129879,1129881,1154080,1159824,1159825,1159826,1159827,1159828,1159831,1159832
CVE References: CVE-2019-20009,CVE-2019-20010,CVE-2019-20011,CVE-2019-20012,CVE-2019-20013,CVE-2019-20014,CVE-2019-20015,CVE-2019-9770,CVE-2019-9771,CVE-2019-9772,CVE-2019-9773,CVE-2019-9774,CVE-2019-9775,CVE-2019-9776,CVE-2019-9777,CVE-2019-9778,CVE-2019-9779
Sources used:
openSUSE Leap 15.1 (src):    libredwg-0.9.3-lp151.2.3.1
Comment 4 Swamp Workflow Management 2020-01-22 23:14:55 UTC
openSUSE-SU-2020:0095-1: An update that solves 17 vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1129868,1129869,1129870,1129873,1129874,1129875,1129876,1129878,1129879,1129881,1154080,1159824,1159825,1159826,1159827,1159828,1159831,1159832
CVE References: CVE-2019-20009,CVE-2019-20010,CVE-2019-20011,CVE-2019-20012,CVE-2019-20013,CVE-2019-20014,CVE-2019-20015,CVE-2019-9770,CVE-2019-9771,CVE-2019-9772,CVE-2019-9773,CVE-2019-9774,CVE-2019-9775,CVE-2019-9776,CVE-2019-9777,CVE-2019-9778,CVE-2019-9779
Sources used:
openSUSE Backports SLE-15-SP1 (src):    libredwg-0.9.3-bp151.2.3.1
Comment 5 Alexandros Toptsoglou 2020-05-04 12:02:35 UTC
Done