Bug 1161061 (CVE-2020-7045)

Summary: VUL-1: CVE-2020-7045: wireshark: BT ATT dissector could crash
Product: [openSUSE] openSUSE Distribution Reporter: Robert Frohl <rfrohl>
Component: SecurityAssignee: Robert Frohl <rfrohl>
Status: RESOLVED INVALID QA Contact: Security Team bot <security-team>
Severity: Minor    
Priority: P5 - None    
Version: Leap 15.1   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/251237/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Robert Frohl 2020-01-16 10:21:26 UTC
CVE-2020-7045

In Wireshark 3.0.x before 3.0.8, the BT ATT dissector could crash. This was
addressed in epan/dissectors/packet-btatt.c by validating opcodes.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-7045
http://people.canonical.com/~ubuntu-security/cve/2020/CVE-2020-7045.html
Comment 1 Robert Frohl 2020-01-16 10:21:58 UTC
don't ship the affected versions