Bug 1174668 (CVE-2020-6070)

Summary: VUL-0: CVE-2020-6070: f2fs-tools: specially crafted f2fs file can cause a logic flaw and out-of-bounds heap operations
Product: [openSUSE] openSUSE Distribution Reporter: Alexandros Toptsoglou <atoptsoglou>
Component: SecurityAssignee: Security Team bot <security-team>
Status: NEW --- QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P3 - Medium    
Version: Leap 15.1   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/264471/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Alexandros Toptsoglou 2020-07-29 12:17:16 UTC
CVE-2020-6070

An exploitable code execution vulnerability exists in the file system checking functionality of fsck.f2fs 1.12.0. A specially crafted f2fs file can cause a logic flaw and out-of-bounds heap operations, resulting in code execution. An attacker can provide a malicious file to trigger this vulnerability.

External Reference:

https://talosintelligence.com/vulnerability_reports/TALOS-2020-0988

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1861728
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-6070
Comment 1 Jan Engelhardt 2021-04-26 15:21:41 UTC
It does not appear that upstream did anything with regard to the report since. (That, or it is not directly discoverable in Git.)