Bug 1175634

Summary: Change default state of "Include recommended packages" checkbox in YaST/"Online Update Configuration"
Product: [openSUSE] openSUSE Distribution Reporter: Alexander Shchadilov <alexander.shchadilov>
Component: YaST2Assignee: YaST Team <yast-internal>
Status: CONFIRMED --- QA Contact: Jiri Srain <jsrain>
Severity: Enhancement    
Priority: P5 - None CC: aherzig, dgonzalez, mrmazda
Version: Leap 15.2Flags: locilka: needinfo? (aherzig)
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://trello.com/c/FjAD3Vl2
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Alexander Shchadilov 2020-08-22 17:26:13 UTC
"Include recommended packages" checkbox in YaST/"Online Update Configuration" is disabled by default (after installing yast2-online-update-configuration). I suggest changing the default state as all other update methods that rely on Libzypp behave differently (by default).
In YaST/"Online Update" this is configurable via "Dependencies"/"Install recommended packages" (enabled by default), other software will honour solver.onlyRequires option from /etc/zypp/zypp.conf (false by default, meaning that recommended packages are installed).
I think that generally a user expects that turning on automatic updates will schedule the same process as that is initiated with updating manually.
Comment 1 David Diaz 2020-08-24 08:47:02 UTC
Hi Alexander, thanks for the request.

Let's put it in the queue to be evaluated.
Comment 2 Lukas Ocilka 2020-08-24 11:48:39 UTC
Well, I believe that such change IS a feature request.
And as such, it needs:

- PjM blessing
- Release notes
- Docu change