Bug 1177862 (CVE-2020-26682)

Summary: VUL-0: CVE-2020-26682: libass: signed integer overflow in the call to outline_stroke() from ass_outline_construct()
Product: [Novell Products] SUSE Security Incidents Reporter: Wolfgang Frisch <wolfgang.frisch>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Major    
Priority: P3 - Medium CC: atoptsoglou, carlos.lopez, pgajdos, smash_bz
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/269427/
Whiteboard: CVSSv3.1:SUSE:CVE-2020-26682:7.8:(AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Wolfgang Frisch 2020-10-19 08:13:51 UTC
CVE-2020-26682

In libass 0.14.0, the `ass_outline_construct`'s call to `outline_stroke` causes
a signed integer overflow.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-26682
https://github.com/libass/libass/pull/432
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-26682
https://github.com/libass/libass/issues/431
Comment 1 Wolfgang Frisch 2020-10-19 08:21:04 UTC
SUSE:SLE-12:Update  Not affected [1]
SUSE:SLE-15:Update  Affected

[1] The outline rendering code was completely rewritten in libass 0.14.0. The old version in SLE-12 might contain other vulnerabilities but not this one.
Comment 3 Petr Gajdos 2021-03-16 08:23:45 UTC
Submitted for 15/libass.

I believe all fixed.
Comment 5 Swamp Workflow Management 2021-03-24 14:30:50 UTC
SUSE-SU-2021:0936-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1177862
CVE References: CVE-2020-26682
JIRA References: 
Sources used:
SUSE Manager Server 4.0 (src):    libass-0.14.0-3.3.1
SUSE Manager Retail Branch Server 4.0 (src):    libass-0.14.0-3.3.1
SUSE Manager Proxy 4.0 (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise Server for SAP 15 (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise Server 15-LTSS (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    libass-0.14.0-3.3.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    libass-0.14.0-3.3.1
SUSE Enterprise Storage 6 (src):    libass-0.14.0-3.3.1
SUSE CaaS Platform 4.0 (src):    libass-0.14.0-3.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Carlos López 2022-09-16 12:19:33 UTC
Done, closing.