Bug 1178013

Summary: Application Crash when using FUSE
Product: [openSUSE] openSUSE Tumbleweed Reporter: B <reiokorn>
Component: KernelAssignee: openSUSE Kernel Bugs <kernel-bugs>
Status: RESOLVED FIXED QA Contact: E-mail List <qa-bugs>
Severity: Normal    
Priority: P5 - None CC: reiokorn, tiwai
Version: Current   
Target Milestone: ---   
Hardware: x86-64   
OS: openSUSE Tumbleweed   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---
Attachments: Crash log

Description B 2020-10-22 11:51:19 UTC
Please read this forum thread, with all the information about that bug that I can give you: 

https://forums.opensuse.org/showthread.php/546202-Cryptomator-Application-Crash-when-using-FUSE?p=2976745#post2976745

btw Leap is unaffected.
Comment 1 Takashi Iwai 2020-10-22 12:23:40 UTC
Could you give the brief descriptions and upload the information rather to Bugzilla instead?  The reference can be gone at any time, but we'd like to keep the information consistently.  Thanks.
Comment 2 B 2020-10-22 16:01:28 UTC
Created attachment 842936 [details]
Crash log
Comment 3 Takashi Iwai 2020-10-22 16:07:24 UTC
Please fill the bug description as well instead of pasting a reference to a forum.

And, is this a kernel regression?  That is, if you boot with the older kernel, does it work again?
Comment 4 B 2020-10-22 16:14:34 UTC
(In reply to Takashi Iwai from comment #1)
> Could you give the brief descriptions and upload the information rather to
> Bugzilla instead?  The reference can be gone at any time, but we'd like to
> keep the information consistently.  Thanks.

Cryptomator is a program with which data intended for the cloud can be encrypted.
The following is made available 
-BuildKit
-AppImage

Under FUSE: in both cases the program crashes when "mounting" any directory after entering the corresponding password.
Under WEBDAV: I get an "unexpected error" message

AFAIK this only happens on Tumbleweed, even with latest snapshot, as of this writing 2020-10-21. Leap seems to be unaffected of the same error.

I posted one crash log a bit earlier but I want to mention this one on the BuildKit which causing essentially the same error = crash.


cb@localhost:~/Downloads/buildkit-linux> ./launcher-linux.sh  
17:26:33.312 [main] DEBUG org.cryptomator.common.Environment - java.library.path: /usr/java/packages/lib:/usr/lib64:/lib64:/lib:/usr
/lib 
17:26:33.315 [main] DEBUG org.cryptomator.common.Environment - user.language: de 
17:26:33.315 [main] DEBUG org.cryptomator.common.Environment - user.region: null 
17:26:33.315 [main] DEBUG org.cryptomator.common.Environment - logback.configurationFile: null 
17:26:33.315 [main] DEBUG org.cryptomator.common.Environment - cryptomator.settingsPath: ~/.config/Cryptomator/settings.json 
17:26:33.315 [main] DEBUG org.cryptomator.common.Environment - cryptomator.ipcPortPath: ~/.config/Cryptomator/ipcPort.bin 
17:26:33.315 [main] DEBUG org.cryptomator.common.Environment - cryptomator.keychainPath: null 
17:26:33.315 [main] DEBUG org.cryptomator.common.Environment - cryptomator.logDir: ~/.local/share/Cryptomator/logs 
17:26:33.315 [main] DEBUG org.cryptomator.common.Environment - cryptomator.mountPointsDir: ~/.local/share/Cryptomator/mnt 
17:26:33.315 [main] DEBUG org.cryptomator.common.Environment - cryptomator.minPwLength: null 
17:26:33.315 [main] DEBUG org.cryptomator.common.Environment - cryptomator.buildNumber: null 
17:26:33.335 [main] DEBUG org.cryptomator.common.ShutdownHook - Registered shutdown hook. 
17:26:33.393 [main] DEBUG org.cryptomator.common.settings.SettingsProvider - Attempting to load settings from /home/cb/.config/Crypt
omator/settings.json 
17:26:33.417 [main] INFO org.cryptomator.common.settings.SettingsProvider - Settings loaded from /home/cb/.config/Cryptomator/settin
gs.json 
17:26:33.670 [main] INFO  org.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.5.8 on Linux 5.8.15-1-default (amd64) 
17:26:33.966 [JavaFX Application Thread] INFO  o.c.ui.launcher.FxApplicationStarter - JavaFX Runtime started. 
17:26:34.151 [JavaFX Application Thread] ERROR o.f.secret.handlers.MessageHandler - org.freedesktop.dbus.exceptions.DBusException: o
rg.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files 
17:26:45.189 [App Background Thread 003] INFO  org.cryptomator.common.vaults.Vault - Storing file name length limit of 220 
# 
# A fatal error has been detected by the Java Runtime Environment: 
# 
#  SIGSEGV (0xb) at pc=0x00007ff8241ee189, pid=3540, tid=3686 
# 
# JRE version: OpenJDK Runtime Environment (15.0+14) (build 15-internal+14-suse-1.9-x8664) 
# Java VM: OpenJDK 64-Bit Server VM (15-internal+14-suse-1.9-x8664, mixed mode, tiered, compressed oops, g1 gc, linux-amd64) 
# Problematic frame: 
# C  [jffi8608120536213508669.so+0x7189] 
# 
# Core dump will be written. Default location: Core dumps may be processed with "/bin/false" (or dumping to /home/cb/Downloads/build
kit-linux/core.3540) 
# 
# An error report file with more information is saved as: 
# /home/cb/Downloads/buildkit-linux/hs_err_pid3540.log 
# 
# If you would like to submit a bug report, please visit: 
#   https://bugreport.java.com/bugreport/crash.jsp 
# 
./launcher-linux.sh: Zeile 11:  3540 Abgebrochen             (Speicherabzug geschrieben) java -cp "libs/*" -Dcryptomator.settingsPat
h="~/.config/Cryptomator/settings.json" -Dcryptomator.ipcPortPath="~/.config/Cryptomator/ipcPort.bin" -Dcryptomator.logDir="~/.local
/share/Cryptomator/logs" -Dcryptomator.mountPointsDir="~/.local/share/Cryptomator/mnt" -Djdk.gtk.version=2 -Xss20m -Xmx512m org.cryp
tomator.launcher.Cryptomator




the "unexpected error" from WEBDAV is this one:

org.cryptomator.common.vaults.Volume$VolumeException: org.cryptomator.frontend.webdav.mount.Mounter$CommandFailedException: Command failed with exit code 2. Expected 0. Stderr: gio: webdav://localhost:42427/tiLe5cNk3dlw/test1: Ort kann nicht eingehängt werden

	at org.cryptomator.common.vaults.WebDavVolume.mount(WebDavVolume.java:65)
	at org.cryptomator.common.vaults.WebDavVolume.mount(WebDavVolume.java:49)
	at org.cryptomator.common.vaults.Vault.unlock(Vault.java:129)
	at org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(UnlockWorkflow.java:103)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:80)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:43)
	at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)
Caused by: org.cryptomator.frontend.webdav.mount.Mounter$CommandFailedException: Command failed with exit code 2. Expected 0. Stderr: gio: webdav://localhost:42427/tiLe5cNk3dlw/test1: Ort kann nicht eingehängt werden

	at org.cryptomator.frontend.webdav.mount.ProcessUtil.assertExitValue(ProcessUtil.java:28)
	at org.cryptomator.frontend.webdav.mount.LinuxGioMounter.mount(LinuxGioMounter.java:39)
	at org.cryptomator.frontend.webdav.servlet.WebDavServletController.mount(WebDavServletController.java:102)
	at org.cryptomator.common.vaults.WebDavVolume.mount(WebDavVolume.java:62)
	... 12 more


Here's the system log

Okt 22 18:12:08 localhost.localdomain systemd[1758]: Started /home/cb/Downloads/cryptomator-1.5.8-x86_64.AppImage.
Okt 22 18:12:08 localhost.localdomain kded5[1954]: Registering ":1.71/StatusNotifierItem" to system tray
Okt 22 18:12:08 localhost.localdomain xembedsniproxy[1968]: Container window visible, stack below
Okt 22 18:12:17 localhost.localdomain kded5[1954]: Service  ":1.71" unregistered
Okt 22 18:12:17 localhost.localdomain systemd[1758]: home-cb-.local-share-Cryptomator-mnt-tiLe5cNk3dlw_7.mount: Succeeded.
Okt 22 18:12:17 localhost.localdomain systemd[1758]: tmp-.mount_crypto7o0veL.mount: Succeeded.
Okt 22 18:12:17 localhost.localdomain systemd[1758]: app-\x2fhome\x2fcb\x2fDownloads\x2fcryptomator\x2d1.5.8\x2dx86_64.AppImage-4d40890610134598889636ad09e5e7cd.scope: Succeeded.
Comment 5 B 2020-10-22 16:17:15 UTC
(In reply to Takashi Iwai from comment #3)
> Please fill the bug description as well instead of pasting a reference to a
> forum.
> 
> And, is this a kernel regression?  That is, if you boot with the older
> kernel, does it work again?

Well, I think so? I only tried it with openSUSE Leap and it worked without issues.
Comment 6 Takashi Iwai 2020-10-22 16:25:50 UTC
(In reply to B from comment #5)
> (In reply to Takashi Iwai from comment #3)
> > Please fill the bug description as well instead of pasting a reference to a
> > forum.
> > 
> > And, is this a kernel regression?  That is, if you boot with the older
> > kernel, does it work again?
> 
> Well, I think so? I only tried it with openSUSE Leap and it worked without
> issues.

That's a different user-space stuff, so cannot judge only from that.
On the TW system, you can install an older kernel that is available in OBS history repo:
  http://download.opensuse.org/history/

Install the older one and check whether you still reproduce the problem with it.

Alternatively, if it worked on Leap 15.2, you can install Leap 15.2 kernel on top of TW system for testing, too.  In either way, use zypper install --oldpackage option.
Comment 7 B 2020-10-22 16:59:20 UTC
(In reply to Takashi Iwai from comment #6)

> That's a different user-space stuff, so cannot judge only from that.
> On the TW system, you can install an older kernel that is available in OBS
> history repo:
>   http://download.opensuse.org/history/
> 
> Install the older one and check whether you still reproduce the problem with
> it.
> 
> Alternatively, if it worked on Leap 15.2, you can install Leap 15.2 kernel
> on top of TW system for testing, too.  In either way, use zypper install
> --oldpackage option.

I'm not sure how to use that command. Do I need to add any repos to find the correct kernel?
Comment 8 B 2020-10-22 17:20:19 UTC
(In reply to B from comment #7)
> (In reply to Takashi Iwai from comment #6)
> 
> > That's a different user-space stuff, so cannot judge only from that.
> > On the TW system, you can install an older kernel that is available in OBS
> > history repo:
> >   http://download.opensuse.org/history/
> > 
> > Install the older one and check whether you still reproduce the problem with
> > it.
> > 
> > Alternatively, if it worked on Leap 15.2, you can install Leap 15.2 kernel
> > on top of TW system for testing, too.  In either way, use zypper install
> > --oldpackage option.
> 
> I'm not sure how to use that command. Do I need to add any repos to find the
> correct kernel?

Alright I added the https://download.opensuse.org/update/leap/15.2/oss//openSUSE:Leap:15.2:Update.repo 
and switched versions of kernel-default via YAST - installed, then restart, advanced options, switched to 

Kernel Version: 5.3.18-lp152.47-default

All other packages are still the same though...

The app does crash like before - so it's not the kernel?
Comment 9 B 2020-10-23 11:23:48 UTC
Looks like the developers were wrong when they referred the application crash to special features of openSUSE Tumbleweed, because the problem now also occurs with new Ubuntu version 20.10. 

Tried it out (on live usb):
Ubuntu 20.10
64-bit
GNOME 3.38.1

# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fbb585ee189, pid=6558, tid=7092
#
# JRE version: OpenJDK Runtime Environment Zulu14.29+23-CA (14.0.2+12) (build 14.0.2+12)
# Java VM: OpenJDK 64-Bit Server VM Zulu14.29+23-CA (14.0.2+12, mixed mode, tiered, compressed oops, g1 gc, linux-amd64)
# Problematic frame:
# C  [jffi4261450707072693211.so+0x7189]

Systemlog

Oct 23 11:05:58 ubuntu AppRun[7283]: Failed to load module "canberra-gtk-module"
Oct 23 11:05:58 ubuntu org.freedesktop.FileManager1[7283]: 11:05:58.958 [main] INFO  org.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.5.8 on Linux 5.8.0-25-generic (amd64)
Oct 23 11:05:59 ubuntu org.freedesktop.FileManager1[7283]: 11:05:59.153 [JavaFX Application Thread] INFO  o.c.ui.launcher.FxApplicationStarter - JavaFX Runtime started.
Oct 23 11:05:59 ubuntu org.freedesktop.FileManager1[7283]: 11:05:59.451 [JavaFX Application Thread] ERROR o.f.secret.handlers.MessageHandler - org.freedesktop.dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: No such interface “org.freedesktop.DBus.Properties” on object at path /org/freedesktop/secrets/collection/login
Oct 23 11:06:00 ubuntu gnome-shell[5623]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x3e00004
Oct 23 11:06:00 ubuntu gnome-shell[5623]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x3e00004
Oct 23 11:06:14 ubuntu systemd[1]: systemd-timedated.service: Succeeded.
Oct 23 11:06:24 ubuntu org.freedesktop.FileManager1[7283]: 11:06:24.911 [App Background Thread 003] INFO  org.cryptomator.common.vaults.Vault - Storing file name length limit of 220
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: #
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: # A fatal error has been detected by the Java Runtime Environment:
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: #
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: #  SIGSEGV (0xb) at pc=0x00007f65fc3ed189, pid=7283, tid=7423
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: #
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: # JRE version: OpenJDK Runtime Environment Zulu14.29+23-CA (14.0.2+12) (build 14.0.2+12)
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: # Java VM: OpenJDK 64-Bit Server VM Zulu14.29+23-CA (14.0.2+12, mixed mode, tiered, compressed oops, g1 gc, linux-amd64)
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: # Problematic frame:
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: # C  [jffi17449612571713990617.so+0x7189]
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: #
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: # Core dump will be written. Default location: Core dumps may be processed with "/usr/share/apport/apport %p %s %c %d %P %E" (or dumping to /home/ubuntu/Downloads/core.7283)
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: #
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: # An error report file with more information is saved as:
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: # /home/ubuntu/Downloads/hs_err_pid7283.log
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: #
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: # If you would like to submit a bug report, please visit:
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: #   http://www.azulsystems.com/support/
Oct 23 11:06:25 ubuntu org.freedesktop.FileManager1[7283]: #
Oct 23 11:06:25 ubuntu systemd[2502]: home-ubuntu-.local-share-Cryptomator-mnt-F9EjrZHwK9kF_1.mount: Succeeded.
Oct 23 11:06:25 ubuntu systemd[1]: home-ubuntu-.local-share-Cryptomator-mnt-F9EjrZHwK9kF_1.mount: Succeeded.
Oct 23 11:06:25 ubuntu systemd[2502]: tmp-.mount_cryptoOnSZIV.mount: Succeeded.
Oct 23 11:06:25 ubuntu systemd[1]: tmp-.mount_cryptoOnSZIV.mount: Succeeded.

Looks like the same error as before under Tumbleweed, now also under Ubuntu
Comment 10 B 2021-11-24 13:51:28 UTC
Fixed by cryptomator devs