Bug 1178375 (CVE-2020-16004)

Summary: VUL-0: chromium: stable update to 86.0.4240.183
Product: [Novell Products] SUSE Security Incidents Reporter: Marcus Meissner <meissner>
Component: IncidentsAssignee: Callum Farmer <gmbr3>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Major    
Priority: P2 - High CC: Andreas.Stieger, atoptsoglou, gmbr3, meissner
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Marcus Meissner 2020-11-03 07:03:08 UTC
https://chromereleases.googleblog.com/search/label/Stable%20updates

The stable channel has been updated to 86.0.4240.183 for Windows, Mac & Linux which will roll out over the coming days/weeks.

A list of all changes is available in the log. Interested in switching release channels?Find out how. If you find a new issue, please let us know by filing a bug. The community help forum is also a great place to reach out for help or learn about common issues.


Security Fixes and Rewards
Note: Access to bug details and links may be kept restricted until a majority of users are updated with a fix. We will also retain restrictions if the bug exists in a third party library that other projects similarly depend on, but haven’t yet fixed.
This update includes 10 security fixes. Below, we highlight fixes that were contributed by external researchers. Please see the Chrome Security Page for more information.
[$15000][1138911] High CVE-2020-16004: Use after free in user interface. Reported by Leecraso and Guang Gong of 360 Alpha Lab working with 360 BugCloud on 2020-10-15
[$15000][1139398] High CVE-2020-16005: Insufficient policy enforcement in ANGLE. Reported by Jaehun Jeong(@n3sk) of Theori on 2020-10-16
[$5000][1133527] High CVE-2020-16006: Inappropriate implementation in V8. Reported by Bill Parks on 2020-09-29
[$1000][1125018] High CVE-2020-16007: Insufficient data validation in installer. Reported by Abdelhamid Naceri (halov) on 2020-09-04
[$TBD][1134107] High CVE-2020-16008: Stack buffer overflow in WebRTC. Reported by Tolya Korniltsev on 2020-10-01
[$NA][1143772] High CVE-2020-16009: Inappropriate implementation in V8. Reported by Clement Lecigne of Google's Threat Analysis Group and Samuel Groß of Google Project Zero on 2020-10-29
[$NA][1144489] High CVE-2020-16011: Heap buffer overflow in UI on Windows. Reported by Sergei Glazunov of Google Project Zero on 2020-11-01

Google is aware of reports that an exploit for CVE-2020-16009 exists in the wild.

We would also like to thank all security researchers that worked with us during the development cycle to prevent security bugs from ever reaching the stable channel.

As usual, our ongoing internal security work was responsible for a wide range of fixes:
[1144284] Various fixes from internal audits, fuzzing and other initiatives

Many of our security bugs are detected using AddressSanitizer, MemorySanitizer, UndefinedBehaviorSanitizer, Control Flow Integrity, libFuzzer, or AFL.


Google Chrome
Prudhvikumar Bommana
Comment 1 Callum Farmer 2020-11-03 09:31:25 UTC
Chromium is me now.

Already in progress.
Comment 2 OBSbugzilla Bot 2020-11-03 10:40:07 UTC
This is an autogenerated message for OBS integration:
This bug (1178375) was mentioned in
https://build.opensuse.org/request/show/845663 15.1+15.2+Backports:SLE-15-SP1 / chromium
https://build.opensuse.org/request/show/845666 Factory / chromium
Comment 3 OBSbugzilla Bot 2020-11-03 11:40:21 UTC
This is an autogenerated message for OBS integration:
This bug (1178375) was mentioned in
https://build.opensuse.org/request/show/845668 Backports:SLE-15-SP2 / chromium+gn
Comment 4 Swamp Workflow Management 2020-11-05 14:15:23 UTC
openSUSE-SU-2020:1829-1: An update that fixes 39 vulnerabilities is now available.

Category: security (important)
Bug References: 1177408,1177936,1178375
CVE References: CVE-2020-15967,CVE-2020-15968,CVE-2020-15969,CVE-2020-15970,CVE-2020-15971,CVE-2020-15972,CVE-2020-15973,CVE-2020-15974,CVE-2020-15975,CVE-2020-15976,CVE-2020-15977,CVE-2020-15978,CVE-2020-15979,CVE-2020-15980,CVE-2020-15981,CVE-2020-15982,CVE-2020-15983,CVE-2020-15984,CVE-2020-15985,CVE-2020-15986,CVE-2020-15987,CVE-2020-15988,CVE-2020-15989,CVE-2020-15990,CVE-2020-15991,CVE-2020-15992,CVE-2020-15999,CVE-2020-16000,CVE-2020-16001,CVE-2020-16002,CVE-2020-16003,CVE-2020-16004,CVE-2020-16005,CVE-2020-16006,CVE-2020-16007,CVE-2020-16008,CVE-2020-16009,CVE-2020-16011,CVE-2020-6557
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP2 (src):    chromium-86.0.4240.183-bp152.2.26.1, gn-0.1807-bp152.2.3.4
Comment 5 Swamp Workflow Management 2020-11-05 17:26:11 UTC
openSUSE-SU-2020:1831-1: An update that fixes 7 vulnerabilities is now available.

Category: security (important)
Bug References: 1178375
CVE References: CVE-2020-16004,CVE-2020-16005,CVE-2020-16006,CVE-2020-16007,CVE-2020-16008,CVE-2020-16009,CVE-2020-16011
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    chromium-86.0.4240.183-lp152.2.45.1
openSUSE Leap 15.1 (src):    chromium-86.0.4240.183-lp151.2.150.1
openSUSE Backports SLE-15-SP1 (src):    chromium-86.0.4240.183-bp151.3.119.1
Comment 6 Andreas Stieger 2020-11-10 15:36:42 UTC
done
Comment 7 Swamp Workflow Management 2020-11-15 23:16:20 UTC
openSUSE-SU-2020:1937-1: An update that fixes 7 vulnerabilities is now available.

Category: security (important)
Bug References: 1178375
CVE References: CVE-2020-16004,CVE-2020-16005,CVE-2020-16006,CVE-2020-16007,CVE-2020-16008,CVE-2020-16009,CVE-2020-16011
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP1 (src):    chromium-86.0.4240.183-bp151.3.125.1
Comment 8 OBSbugzilla Bot 2021-12-15 09:40:56 UTC
This is an autogenerated message for OBS integration:
This bug (1178375) was mentioned in
https://build.opensuse.org/request/show/940663 Backports:SLE-12-SP3 / chromium