Bug 1179349 (CVE-2019-20925)

Summary: VUL-0: CVE-2019-20925: mongodb: DoS via malformed network packet
Product: [Novell Products] SUSE Security Incidents Reporter: Alexandros Toptsoglou <atoptsoglou>
Component: IncidentsAssignee: Cloud Bugs <cloud-bugs>
Status: RESOLVED WONTFIX QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P5 - None CC: smash_bz
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/272215/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Alexandros Toptsoglou 2020-11-27 19:00:29 UTC
CVE-2019-20925

An unauthenticated client can trigger denial of service by issuing specially crafted wire protocol messages, which cause the message decompressor to incorrectly allocate memory. This issue affects: MongoDB Inc. MongoDB Server v4.2 versions prior to 4.2.1; v4.0 versions prior to 4.0.13; v3.6 versions prior to 3.6.15; v3.4 versions prior to 3.4.24.

Reference:
https://jira.mongodb.org/browse/SERVER-43751

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1901527
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-20925
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-20925
https://jira.mongodb.org/browse/SERVER-43751
Comment 1 Alexandros Toptsoglou 2020-11-27 19:02:14 UTC
Only in SOC 7. Closing as Wontfix since mongodb is not reachable to attackers.