Bug 1186020 (CVE-2021-3531)

Summary: VUL-0: CVE-2021-3531: ceph: RGW unauthenticated denial of service
Product: [Novell Products] SUSE Security Incidents Reporter: Gianluca Gabrielli <gianluca.gabrielli>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P3 - Medium CC: ceph-bugs, gabriele.sonnu, meissner, ncutler, security-team, tserong
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/284211
Whiteboard: CVSSv3.1:SUSE:CVE-2021-3531:7.5:(AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Comment 2 Marcus Meissner 2021-05-14 07:11:30 UTC
public now

https://docs.ceph.com/en/latest/releases/octopus/

rgw: RGWSwiftWebsiteHandler::is_web_dir checks empty subdir_name (CVE-2021-3531: Swift API denial of service, Felix Huettner)
Comment 3 Gianluca Gabrielli 2021-05-14 07:41:40 UTC
Affected packages:

- SUSE:SLE-12-SP3:Update/ceph     12.2.13+git.1609861337.ff66d09906
- SUSE:SLE-15-SP1:Update/ceph     14.2.20.402+g6aa76c6815
- SUSE:SLE-15-SP2:Update/ceph     15.2.11.83+g8a15f484c2
- SUSE:SLE-15:Update/ceph         13.2.4.125+gad802694f5
- openSUSE:Factory/ceph           16.2.3.26+g422932e923

Upstream patch: https://github.com/ceph/ceph/commit/f44a8ae8aa27ecef69528db9aec220f12492810e.patch
Comment 4 Nathan Cutler 2021-05-17 12:36:36 UTC
(In reply to Gianluca Gabrielli from comment #3)
> Affected packages:
> 
> - SUSE:SLE-12-SP3:Update/ceph     12.2.13+git.1609861337.ff66d09906
> - SUSE:SLE-15-SP1:Update/ceph     14.2.20.402+g6aa76c6815
> - SUSE:SLE-15-SP2:Update/ceph     15.2.11.83+g8a15f484c2
> - SUSE:SLE-15:Update/ceph         13.2.4.125+gad802694f5
> - openSUSE:Factory/ceph           16.2.3.26+g422932e923

@Gianluca: the comment I posted on Bug 1185619 also applies to this bug. The following code streams are not affected so we would not ordinarily apply any patches to them:

- SUSE:SLE-12-SP3:Update/ceph     12.2.13+git.1609861337.ff66d09906
- SUSE:SLE-15:Update/ceph         13.2.4.125+gad802694f5
Comment 7 Swamp Workflow Management 2021-06-02 19:20:20 UTC
SUSE-SU-2021:1834-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1185619,1186020,1186021
CVE References: CVE-2021-3509,CVE-2021-3524,CVE-2021-3531
JIRA References: 
Sources used:
SUSE MicroOS 5.0 (src):    ceph-15.2.12.83+g528da226523-3.25.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    ceph-15.2.12.83+g528da226523-3.25.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    ceph-15.2.12.83+g528da226523-3.25.1
SUSE Enterprise Storage 7 (src):    ceph-15.2.12.83+g528da226523-3.25.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2021-06-02 19:31:14 UTC
SUSE-SU-2021:1835-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1185619,1186020,1186021
CVE References: CVE-2021-3509,CVE-2021-3524,CVE-2021-3531
JIRA References: 
Sources used:
SUSE Manager Server 4.0 (src):    ceph-14.2.21.403+g69ab6ea274d-3.63.1
SUSE Manager Retail Branch Server 4.0 (src):    ceph-14.2.21.403+g69ab6ea274d-3.63.1
SUSE Manager Proxy 4.0 (src):    ceph-14.2.21.403+g69ab6ea274d-3.63.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    ceph-14.2.21.403+g69ab6ea274d-3.63.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    ceph-14.2.21.403+g69ab6ea274d-3.63.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    ceph-14.2.21.403+g69ab6ea274d-3.63.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    ceph-14.2.21.403+g69ab6ea274d-3.63.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    ceph-14.2.21.403+g69ab6ea274d-3.63.1
SUSE Enterprise Storage 6 (src):    ceph-14.2.21.403+g69ab6ea274d-3.63.1
SUSE CaaS Platform 4.0 (src):    ceph-14.2.21.403+g69ab6ea274d-3.63.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 9 Swamp Workflow Management 2021-06-03 22:24:15 UTC
openSUSE-SU-2021:0833-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1185619,1186020,1186021
CVE References: CVE-2021-3509,CVE-2021-3524,CVE-2021-3531
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    ceph-15.2.12.83+g528da226523-lp152.2.18.1, ceph-test-15.2.12.83+g528da226523-lp152.2.18.1
Comment 10 Swamp Workflow Management 2021-07-10 23:10:11 UTC
openSUSE-SU-2021:1834-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1185619,1186020,1186021
CVE References: CVE-2021-3509,CVE-2021-3524,CVE-2021-3531
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    ceph-15.2.12.83+g528da226523-3.25.1, ceph-test-15.2.12.83+g528da226523-3.25.1
Comment 13 Gabriele Sonnu 2022-04-06 12:37:14 UTC
All done.