Bug 1187487 (CVE-2021-34825)

Summary: VUL-0: CVE-2021-34825: quassel: when --require-ssl is enabled and there is no certificate to load it will accept plaintext connections
Product: [openSUSE] openSUSE Distribution Reporter: Gianluca Gabrielli <gianluca.gabrielli>
Component: OtherAssignee: E-mail List <kde-maintainers>
Status: NEW --- QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P3 - Medium    
Version: Leap 15.2   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/302474/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Gianluca Gabrielli 2021-06-18 10:18:13 UTC
Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

Reference:
https://github.com/quassel/quassel/pull/581

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1973440
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-34825
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-34825
https://github.com/quassel/quassel/pull/581