Bug 1189914

Summary: Install failure during partitioning, with 32-bit Tumbleweed
Product: [openSUSE] openSUSE Tumbleweed Reporter: Neil Rickert <nwr10cst-oslnx>
Component: InstallationAssignee: YaST Team <yast-internal>
Status: CONFIRMED --- QA Contact: Jiri Srain <jsrain>
Severity: Normal    
Priority: P5 - None CC: mfilka
Version: Current   
Target Milestone: ---   
Hardware: x86-64   
OS: Other   
URL: https://trello.com/c/eavH8w1K
Whiteboard:
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---
Attachments: Screenshot showing the error during install
Yast logs for the failed install
"fdisk -l /dev/sda" output from rescue system after failed install

Description Neil Rickert 2021-08-29 23:26:13 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0
Build Identifier: 

I was attempting to install to a VM using 32-bit EFI.  I used the iso for 20210826 to create my own USB installer (partition 1 is a copy of what's on the iso, and partition 2 is an EFI partition where I have installed grub to boot the installer.

There were errors reported during partitioning (during the actual install, not the proposal section), but they allowed me to continue.  From the error message, it looked as if "parted" was trying to remove any NVRAM entries corresponding to deleted partitions, but "efibootmgr" is apparently not on the install media so that failed.

Since it allowed me to continue, I did.  But this led to weird failures during the install.

I repeated this, with the same result.

I then booted the rescue system.  And "fdisk -l /dev/sda" looked wrong.  Apparently "parted" had failed to write the updated partition table to the disk.  That was probably the cause of the error.

While in the rescue system, I deleted all but the EFI partition.  Then I repeated my install attempt.  This time, it mostly worked.  There was one error message, but I'll report a separate bug for that.

Will attach relevant information.

Reproducible: Always
Comment 1 Neil Rickert 2021-08-29 23:28:15 UTC
Created attachment 852120 [details]
Screenshot showing the error during install
Comment 2 Neil Rickert 2021-08-29 23:29:35 UTC
Created attachment 852121 [details]
Yast logs for the failed install
Comment 3 Neil Rickert 2021-08-29 23:30:26 UTC
Created attachment 852122 [details]
"fdisk -l /dev/sda" output from rescue system after failed install