Bug 1195667 (CVE-2022-21712)

Summary: VUL-0: CVE-2022-21712: python-Twisted: secret exposure in cross-origin redirects
Product: [Novell Products] SUSE Security Incidents Reporter: Carlos López <carlos.lopez>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Major    
Priority: P3 - Medium CC: smash_bz
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/322921/
Whiteboard: CVSSv3.1:SUSE:CVE-2022-21712:7.1:(AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N)
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Comment 1 Carlos López 2022-02-08 10:10:09 UTC
Affected:
 - SUSE:SLE-12:Update
 - SUSE:SLE-15-SP2:Update
 - SUSE:SLE-15-SP4:Update
 - openSUSE:Factory
Comment 2 Matej Cepl 2022-02-11 12:16:19 UTC
According to https://github.com/twisted/twisted/security/advisories/GHSA-92x2-jw7w-xvvx 22.1 (which is what we have in Factory) has been patched.
Comment 3 Matej Cepl 2022-02-11 12:22:36 UTC
SLE-15-SP4:GA https://build.suse.de/request/show/264768
Comment 9 Swamp Workflow Management 2022-02-18 14:25:10 UTC
openSUSE-SU-2022:0499-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1195667
CVE References: CVE-2022-21712
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    python-Twisted-19.10.0-3.6.1
openSUSE Leap 15.3 (src):    python-Twisted-19.10.0-3.6.1
Comment 10 Swamp Workflow Management 2022-02-18 14:38:22 UTC
SUSE-SU-2022:0499-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1195667
CVE References: CVE-2022-21712
JIRA References: 
Sources used:
SUSE Manager Server 4.1 (src):    python-Twisted-19.10.0-3.6.1
SUSE Manager Retail Branch Server 4.1 (src):    python-Twisted-19.10.0-3.6.1
SUSE Manager Proxy 4.1 (src):    python-Twisted-19.10.0-3.6.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    python-Twisted-19.10.0-3.6.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    python-Twisted-19.10.0-3.6.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    python-Twisted-19.10.0-3.6.1
SUSE Linux Enterprise Realtime Extension 15-SP2 (src):    python-Twisted-19.10.0-3.6.1
SUSE Linux Enterprise Module for Server Applications 15-SP3 (src):    python-Twisted-19.10.0-3.6.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    python-Twisted-19.10.0-3.6.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    python-Twisted-19.10.0-3.6.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    python-Twisted-19.10.0-3.6.1
SUSE Enterprise Storage 7 (src):    python-Twisted-19.10.0-3.6.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 13 Swamp Workflow Management 2022-03-04 17:22:46 UTC
SUSE-SU-2022:0734-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1195667
CVE References: CVE-2022-21712
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    python-Twisted-15.2.1-9.11.1
SUSE OpenStack Cloud Crowbar 8 (src):    python-Twisted-15.2.1-9.11.1
SUSE OpenStack Cloud 9 (src):    python-Twisted-15.2.1-9.11.1
SUSE OpenStack Cloud 8 (src):    python-Twisted-15.2.1-9.11.1
SUSE Linux Enterprise Module for Web Scripting 12 (src):    python-Twisted-15.2.1-9.11.1
HPE Helion Openstack 8 (src):    python-Twisted-15.2.1-9.11.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 15 Carlos López 2022-06-10 09:02:59 UTC
Done, closing.