Bug 1197135 (CVE-2021-25220)

Summary: VUL-0: CVE-2021-25220: bind: forwarders may be cached causing it to obtain and pass on potentially incorrect answers
Product: [Novell Products] SUSE Security Incidents Reporter: Alexander Bergmann <abergmann>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: IN_PROGRESS --- QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P3 - Medium CC: abergmann, ebischoff, gianluca.gabrielli, josef.moellers, meissner, security-team
Version: unspecifiedFlags: josef.moellers: needinfo? (abergmann)
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/326255/
Whiteboard: CVSSv3.1:SUSE:CVE-2021-25220:6.8:(AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:N)
Found By: --- Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---
Attachments: Functional changes between bind versions 9.9.9 and 9.11.22

Description Alexander Bergmann 2022-03-15 14:04:44 UTC
Via distros:

Date: Tue, 15 Mar 2022 13:38:28 +0000
From: ISC Security Officer <security-officer@isc.org>

CVE: CVE-2021-25220

Document version: 1.0

Posting date: 16 March 2022

Program impacted: BIND

Versions affected:

BIND

     9.11.0 -> 9.11.36
     9.12.0 -> 9.16.26
     9.17.0 -> 9.18.0

BIND Supported Preview Editions:

     9.11.4-S1 -> 9.11.36-S1
     9.16.8-S1 -> 9.16.26-S1

Versions of BIND 9 earlier than those shown - back to 9.1.0, including
Supported Preview Editions - are also believed to be affected but have not
been tested as they are EOL.

Severity: Medium

Exploitable: Remotely

Description:

When using forwarders, bogus NS records supplied by, or via, those
forwarders may be cached and used by named if it needs to recurse for any
reason, causing it to obtain and pass on potentially incorrect answers.

Some examples of configurations that will be vulnerable are:

     Resolvers using per zone or global forwarding with forward first
     (forward first is the default).
     Resolvers not using global forwarding, but with per-zone forwarding
     with either forward first (the default) or forward only.
     Resolvers configured with global forwarding along with zone statements
     that disable forwarding for part of the DNS namespace.

Authoritative-only BIND 9 servers are not vulnerable to this flaw.

Impact:

The cache could become poisoned with incorrect records leading to queries
being made to the wrong servers, which might also result in false
information being returned to clients.

CVSS Score: 6.8

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:N/E:U/RL:U/RC:C

For more information on the Common Vulnerability Scoring System and to
obtain your specific environmental score please visit:
https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:N/AC:L/PR:H/
UI:N/S:C/C:N/I:H/A:N/E:U/RL:U/RC:C&version=3.1.

Workarounds:

If applicable, modify your configuration to either remove all forwarding
or all possibility of recursion. Depending on your use-case, it may be
possible to use other zone types to replace forward zones.

Active exploits:

We are not aware of any active exploits.

Solution:

Upgrade to the patched release most closely related to your current
version of BIND:

     BIND 9.11.37
     BIND 9.16.27
     BIND 9.18.1

BIND Supported Preview Edition is a special feature preview branch of BIND
provided to eligible ISC support customers.

     BIND 9.11.37-S1
     BIND 9.16.27-S1

Acknowledgments:

ISC would like to thank Xiang Li, Baojun Liu, and Chaoyi Lu from Network
and Information Security Lab, Tsinghua University and Changgen Zou from Qi
An Xin Group Corp. for discovering and reporting this issue.

Document revision history:

1.0 Early Notification, 9 March 2022

Related documents:

See our BIND 9 Security Vulnerability Matrix for a complete listing of
security vulnerabilities and versions affected.

Do you still have questions? Questions regarding this advisory should go
to security-officer@isc.org. To report a new issue, please encrypt your
message using security-officer@isc.org's PGP key which can be found here:
https://www.isc.org/pgpkey/. If you are unable to use encrypted email, you
may also report new issues at: https://www.isc.org/reportbug/.

Note:

ISC patches only currently supported versions. When possible we indicate
EOL versions affected. (For current information on which versions are
actively supported, please see https://www.isc.org/download/.)

ISC Security Vulnerability Disclosure Policy:

Details of our current security advisory policy and practice can be found
in the ISC Software Defect and Security Vulnerability Disclosure Policy at
https://kb.isc.org/docs/aa-00861.

The Knowledgebase article https://kb.isc.org/docs/CVE-2021-25220 is the
complete and official security advisory document.

Legal Disclaimer:

Internet Systems Consortium (ISC) is providing this notice on an "AS IS"
basis. No warranty or guarantee of any kind is expressed in this notice
and none should be implied. ISC expressly excludes and disclaims any
warranties regarding this notice or materials referred to in this notice,
including, without limitation, any implied warranty of merchantability,
fitness for a particular purpose, absence of hidden defects, or of
non-infringement. Your use or reliance on this notice or materials
referred to in this notice is at your own risk. ISC may change this notice
that omits the document URL is an uncontrolled copy. Uncontrolled copies
may lack important information, be out of date, or contain factual errors.
Comment 2 Alexander Bergmann 2022-03-15 15:29:02 UTC
Created attachment 856998 [details]
bind-9.11.37-0001-CVE-2021-25220.patch
Comment 3 Alexander Bergmann 2022-03-15 15:29:17 UTC
Created attachment 856999 [details]
bind-9.16.27-0001-CVE-2021-25220.patch
Comment 4 Alexander Bergmann 2022-03-15 15:29:30 UTC
Created attachment 857000 [details]
bind-9.18.1-0001-CVE-2021-25220.patch
Comment 5 Josef Möllers 2022-03-16 14:21:51 UTC
SUSE:SLE-12-SP4:Update - sr#267667
SUSE:SLE-15-SP3:Update - sr#267668
SUSE:SLE-15-SP4:Update - sr#267669
SUSE:SLE-15:Update - 267670
Factory will be sumbitted tomorrow.
Comment 7 Gianluca Gabrielli 2022-03-17 07:54:45 UTC
Public: https://kb.isc.org/docs/CVE-2021-25220
Comment 10 Swamp Workflow Management 2022-03-21 14:18:16 UTC
SUSE-SU-2022:0908-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1197135
CVE References: CVE-2021-25220
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    bind-9.11.22-3.40.1
SUSE OpenStack Cloud 9 (src):    bind-9.11.22-3.40.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    bind-9.11.22-3.40.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    bind-9.11.22-3.40.1
SUSE Linux Enterprise Server 12-SP5 (src):    bind-9.11.22-3.40.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    bind-9.11.22-3.40.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2022-03-24 17:20:01 UTC
openSUSE-SU-2022:0945-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1197135
CVE References: CVE-2021-25220
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    bind-9.16.6-150300.22.16.1
openSUSE Leap 15.3 (src):    bind-9.16.6-150300.22.16.1
Comment 12 Swamp Workflow Management 2022-03-24 17:20:35 UTC
openSUSE-SU-2022:0946-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1197135
CVE References: CVE-2021-25220
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    bind-9.16.6-150000.12.60.1
openSUSE Leap 15.3 (src):    bind-9.16.6-150000.12.60.1
Comment 13 Swamp Workflow Management 2022-03-24 17:21:37 UTC
SUSE-SU-2022:0946-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1197135
CVE References: CVE-2021-25220
JIRA References: 
Sources used:
SUSE Manager Server 4.1 (src):    bind-9.16.6-150000.12.60.1
SUSE Manager Retail Branch Server 4.1 (src):    bind-9.16.6-150000.12.60.1
SUSE Manager Proxy 4.1 (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise Server for SAP 15 (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise Server 15-LTSS (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise Realtime Extension 15-SP2 (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    bind-9.16.6-150000.12.60.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    bind-9.16.6-150000.12.60.1
SUSE Enterprise Storage 7 (src):    bind-9.16.6-150000.12.60.1
SUSE Enterprise Storage 6 (src):    bind-9.16.6-150000.12.60.1
SUSE CaaS Platform 4.0 (src):    bind-9.16.6-150000.12.60.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 14 Swamp Workflow Management 2022-03-24 17:22:20 UTC
SUSE-SU-2022:0945-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1197135
CVE References: CVE-2021-25220
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP4 (src):    bind-9.16.6-150300.22.16.1
SUSE Linux Enterprise Module for Server Applications 15-SP3 (src):    bind-9.16.6-150300.22.16.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    bind-9.16.6-150300.22.16.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    bind-9.16.6-150300.22.16.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 22 Josef Möllers 2022-04-28 09:23:24 UTC
Created attachment 858490 [details]
Functional changes between bind versions 9.9.9 and 9.11.22

The CHANGES file in the source RPM lists ALL the changes. Quite a lot are bug fixes and fixed security issues as well as documentation changes.

This list is the list of 221 functional changes (ie those marked "[func]") compiled from the CHANGES file in the source RPM. I have worked through it and tried to separate the list into (more-or-less)
* "regular" changes, ie those that added new options or functionality while retaining old settings as the default
* "important" changes, ie those that change defaults or added to statistics or otherwise programs' outputs and thus may have an impact on postprocessing this output.

HTH
Comment 26 Josef Möllers 2022-05-02 15:24:31 UTC
SLE-11-SP2:Update (Teradata) fixed with https://build.suse.de/request/show/271228
Comment 27 Josef Möllers 2022-05-03 12:26:12 UTC
SUSE:SLE-12-SP1:Update - https://build.suse.de/request/show/271288
Comment 29 Swamp Workflow Management 2022-05-31 16:18:13 UTC
SUSE-SU-2022:1616-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1197135
CVE References: CVE-2021-25220
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 8 (src):    bind-9.9.9P1-63.34.1
SUSE OpenStack Cloud 8 (src):    bind-9.9.9P1-63.34.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    bind-9.9.9P1-63.34.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    bind-9.9.9P1-63.34.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    bind-9.9.9P1-63.34.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    bind-9.9.9P1-63.34.1
HPE Helion Openstack 8 (src):    bind-9.9.9P1-63.34.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 30 Swamp Workflow Management 2022-08-09 16:24:03 UTC
SUSE-SU-2022:2713-1: An update that solves three vulnerabilities, contains one feature and has two fixes is now available.

Category: security (important)
Bug References: 1192146,1197135,1197136,1199044,1200685
CVE References: CVE-2021-25219,CVE-2021-25220,CVE-2022-0396
JIRA References: SLE-24600
Sources used:
openSUSE Leap 15.4 (src):    bind-9.16.31-150400.5.6.1
SUSE Linux Enterprise Module for Server Applications 15-SP4 (src):    bind-9.16.31-150400.5.6.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    bind-9.16.31-150400.5.6.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.