Bug 1197456 (CVE-2021-28278)

Summary: VUL-1: CVE-2021-28278: A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the RemoveSectionType function in jpgfile.c.
Product: [openSUSE] openSUSE Distribution Reporter: Alexander Bergmann <abergmann>
Component: BasesystemAssignee: Security Team bot <security-team>
Status: IN_PROGRESS --- QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P4 - Low CC: sbrabec
Version: Leap 15.3   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/327046/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Alexander Bergmann 2022-03-24 06:38:05 UTC
CVE-2021-28278

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the
RemoveSectionType function in jpgfile.c.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-28278
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28278
https://github.com/Matthias-Wandel/jhead/issues/15
Comment 1 Stanislav Brabec 2022-05-25 21:06:50 UTC
According to the description, the vulnerability exists in jhead 3.04 and 3.05.

Factory & 15.4 contains 3.06.0.1. It is already fixed.
15.3 contains 3.00. It is not affected according to the description. But looking into the patch, I am able to backport it, so it seems to be safe to apply.
Comment 2 Stanislav Brabec 2022-05-25 21:57:48 UTC
There is a strange thing in Backports:
openSUSE:Backports:SLE-15:Update contains version 3.00
openSUSE:Backports:SLE-15-SP1:Update contains version 3.00
openSUSE:Backports:SLE-15-SP2:Update contains version 3.06.0.1
openSUSE:Backports:SLE-15-SP3:Update contains version 3.00
openSUSE:Backports:SLE-15-SP4:Update contains version 3.06.0.1, but a slightly different spec than SP2

That is why I suggest to fix this bug by updating all repositories to 3.06.0.1.

It is a binary tool, there are no known incompatibilities.
Comment 3 OBSbugzilla Bot 2022-07-25 00:40:15 UTC
This is an autogenerated message for OBS integration:
This bug (1197456) was mentioned in
https://build.opensuse.org/request/show/990913 Backports:SLE-15-SP3 / jhead
Comment 4 Stanislav Brabec 2022-07-25 01:25:03 UTC
Submitted 3.06.0.1 for:
openSUSE:Backports:SLE-15-SP3:Update: https://build.opensuse.org/request/show/990913
openSUSE:Backports:SLE-15-SP1:Update: BuildService API error: Server did not define a default maintenance project, can't submit.
openSUSE:Backports:SLE-15:Update: BuildService API error: Server did not define a default maintenance project, can't submit.

If SLE 15 and SP1 are wanted, please tell me where to submit.