Bug 1199953 (CVE-2022-31622)

Summary: VUL-0: CVE-2022-31622: mariadb,mariadb-100: MariaDB Server before 10.7 is vulnerable to Denial of Service. In extra/mariabackup/ds_compress.cc
Product: [Novell Products] SUSE Security Incidents Reporter: Gianluca Gabrielli <gianluca.gabrielli>
Component: IncidentsAssignee: Security Team bot <security-team>
Status: NEW --- QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P3 - Medium CC: calmeidadeoliveira, security-team
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/332954/
Whiteboard: CVSSv3.1:SUSE:CVE-2022-31622:5.9:(AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H)
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Gianluca Gabrielli 2022-05-26 15:19:51 UTC
MariaDB Server before 10.7 is vulnerable to Denial of Service. In
extra/mariabackup/ds_compress.cc, when an error occurs (pthread_create returns a
nonzero value) while executing the method create_worker_threads, the held lock
is not released correctly, which allows local users to trigger a denial of
service due to the deadlock.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-31622
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-31622
https://github.com/MariaDB/server/commit/e1eb39a446c30b8459c39fd7f2ee1c55a36e97d2
https://jira.mariadb.org/browse/MDEV-26561?filter=-2
Comment 1 Gianluca Gabrielli 2022-05-26 15:20:32 UTC
Affected package:
 - SUSE:SLE-12-SP3:Update:Products:Cloud8:Update/mariadb

Upstream patch [0].

[0] https://github.com/MariaDB/server/commit/e1eb39a446c30b8459c39fd7f2ee1c55a36e97d2
Comment 3 Christian Almeida de Oliveira 2022-05-30 08:39:13 UTC
based on comment #2, back to Security team.