Bug 1201909 (CVE-2021-33464)

Summary: VUL-1: CVE-2021-33464: yasm: heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c
Product: [Novell Products] SUSE Security Incidents Reporter: Carlos López <carlos.lopez>
Component: IncidentsAssignee: Michael Vetter <mvetter>
Status: NEW --- QA Contact: Security Team bot <security-team>
Severity: Minor    
Priority: P4 - Low CC: security-team
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/338224/
Whiteboard: CVSSv3.1:SUSE:CVE-2021-33464:3.3:(AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L)
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Carlos López 2022-07-27 08:19:41 UTC
CVE-2021-33464

An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow
in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-33464
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-33464
https://github.com/yasm/yasm/issues/164
https://gist.github.com/Clingto/bb632c0c463f4b2c97e4f65f751c5e6d