Bug 1202419

Summary: [Build 9.1] openQA test fails in upgrade_select - two IBM modules are not ready at sles15sp5
Product: [openSUSE] PUBLIC SUSE Linux Enterprise Server 15 SP5 Reporter: yutao wang <yuwang>
Component: OtherAssignee: SCC Bugs <scc-bugs>
Status: RESOLVED FIXED QA Contact:
Severity: Normal    
Priority: P1 - Urgent CC: chcao, hluo, leli, llzhao, tschmidt, vasilios.anastasiadis, wegao, ysun, yuwang
Version: unspecifiedKeywords: Migration
Target Milestone: ---Flags: tschmidt: needinfo? (yuwang)
Hardware: PowerPC-64   
OS: SLES 15   
URL: https://openqa.suse.de/tests/9329377/modules/upgrade_select/steps/5
Whiteboard:
Found By: openQA Services Priority:
Business Priority: Blocker: Yes
Marketing QA Status: --- IT Deployment: ---
Attachments: yast2 logs

Description yutao wang 2022-08-16 07:50:04 UTC
Hardware: ppc64le
Migration: sles12sp5 with IBM DLPAR Utils and IBM DLPAR sdk migration to sles15sp5
****************************************************************
## Observation

openQA test in scenario sle-15-SP5-Migration-from-SLE12-SPx-ppc64le-offline_sles12sp5_pscc_idu-ids_all_full@ppc64le fails in
[upgrade_select](https://openqa.suse.de/tests/9329377/modules/upgrade_select/steps/5)



## Reproducible

Fails since (at least) Build [9.1](https://openqa.suse.de/tests/9329377)



## Further details

Always latest result in this scenario: [latest](https://openqa.suse.de/tests/latest?arch=ppc64le&distri=sle&flavor=Migration-from-SLE12-SPx&machine=ppc64le&test=offline_sles12sp5_pscc_idu-ids_all_full&version=15-SP5)
***************************************************************
Test steps:
1. Installed sles12sp5 with IBM DLPAR Utils and IBM DLPAR sdk
2. Offline migration to sles15sp5
3. Got error message:
No migration product found
Comment 1 Stefan Weiberg 2022-08-17 13:52:39 UTC
"IBM POWER Advance Toolchain for SLE 15 ppc64le" and "IBM POWER Tools
for SLE 15 ppc64le" need to be enabled for SLES 15 SP5 and SLES for SAP 15 SP5.
Comment 2 Thomas Schmidt 2022-08-17 15:54:19 UTC
Tracked at https://trello.com/c/dlxeuHdJ/4600-add-ibm-modules-to-sle15sp5 - I'll ping you when it's there.
Comment 3 Thomas Schmidt 2022-08-19 12:56:54 UTC
The IBM modules are available now on SLE15SP5 and SAP15SP5, please see: 
https://scc.suse.com/admin/products/2076
https://scc.suse.com/admin/products/2077
Comment 4 Vasileios ANastasiadis 2022-09-07 10:12:36 UTC
See https://openqa.suse.de/tests/9458757#step/system_prepare/24, IBM Power tools is activated, but IBM Advance Toolchain is not, leading the test to fail.

(also see activated/deactivated status in https://openqa.suse.de/tests/9458757#step/system_prepare/21)
Comment 5 Vasileios ANastasiadis 2022-09-07 10:37:15 UTC
Created attachment 861346 [details]
yast2 logs
Comment 6 Thomas Schmidt 2022-09-07 16:02:36 UTC
https://openqa.suse.de/tests/9458757#step/scc_registration/15 shows that the IBM DLPAR SDK for SLE 12 repo gets deactivated during the migration. 
That's most probably due to that product not properly providing the -release package that's needed for the registration stack to detect it's installed. 

I'd suggest to change the test for not testing the automatic upgrade of IBM DLPAR SDK. There some long existing issues for IBM to properly create those -release packages, and I'm not sure they'll fix it for SLE12.
Comment 7 Stefan Weiberg 2022-11-02 15:14:33 UTC
Resolved, modules are now enabled. See comment#6 regarding the test adjustment.