Bug 1202547 (CVE-2021-32862)

Summary: VUL-0: CVE-2021-32862: python-nbconvert: Cross-site scripting vulnerabilities in nbconvert
Product: [openSUSE] openSUSE Distribution Reporter: Hu <cathy.hu>
Component: SecurityAssignee: Security Team bot <security-team>
Status: NEW --- QA Contact: Security Team bot <security-team>
Severity: Minor    
Priority: P3 - Medium    
Version: Leap 15.4   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/340282/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Hu 2022-08-19 07:29:23 UTC
CVE-2021-32862

The GitHub Security Lab discovered sixteen ways to exploit a cross-site
scripting vulnerability in nbconvert. When using nbconvert to generate an HTML
version of a user-controllable notebook, it is possible to inject arbitrary HTML
which may lead to cross-site scripting (XSS) vulnerabilities if these HTML
notebooks are served by a web server (eg: nbviewer).

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-32862
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-32862
https://github.com/jupyter/nbconvert/security/advisories/GHSA-9jmq-rx5f-8jwq
https://github.com/jupyter/nbviewer/security/advisories/GHSA-h274-fcvj-h2wm
Comment 1 Hu 2022-08-19 07:30:25 UTC
Affected:
- openSUSE:Backports:SLE-15-SP3/python-nbconvert  5.6.1
- openSUSE:Backports:SLE-15-SP4/python-nbconvert  5.6.1

Not Affected:
- openSUSE:Factory/python-nbconvert               6.5.3
Comment 2 Arun Persaud 2022-08-20 15:30:59 UTC
Should probably be assigned to someone else... seems Factory already has the fix?