Bug 1203162 (CVE-2021-3427)

Summary: VUL-0: CVE-2021-3427: deluge: XSS in webui via crafted torrent file
Product: [openSUSE] openSUSE Distribution Reporter: Carlos López <carlos.lopez>
Component: SecurityAssignee: Security Team bot <security-team>
Status: NEW --- QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P3 - Medium CC: andythe_great
Version: Leap 15.4   
Target Milestone: ---   
Hardware: Other   
OS: Other   
URL: https://smash.suse.de/issue/340943/
Whiteboard:
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Carlos López 2022-09-06 11:06:47 UTC
rh#2124452

The Deluge Web-UI is vulnerable to XSS through a crafted torrent file. The the data from torrent files is not properly sanitised as it's interpreted directly as HTML. Someone who supplies the user with a malicious torrent file can execute arbitrary Javascript code in the context of the user's browser session.

https://groups.google.com/g/deluge-dev/c/e5zh7wT0rEg
https://dev.deluge-torrent.org/ticket/3459

References:
https://bugzilla.redhat.com/show_bug.cgi?id=2124452
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-3427
https://www.cve.org/CVERecord?id=CVE-2021-3427
https://groups.google.com/g/deluge-dev/c/e5zh7wT0rEg
https://dev.deluge-torrent.org/ticket/3459
Comment 1 Carlos López 2022-09-06 11:10:20 UTC
Assigning to Dirk for backports - feel free to reassign if somebody else can take it. Factory is already fixed.
Comment 2 OBSbugzilla Bot 2022-09-12 12:25:05 UTC
This is an autogenerated message for OBS integration:
This bug (1203162) was mentioned in
https://build.opensuse.org/request/show/1002903 Factory / deluge
Comment 3 OBSbugzilla Bot 2022-09-16 13:55:03 UTC
This is an autogenerated message for OBS integration:
This bug (1203162) was mentioned in
https://build.opensuse.org/request/show/1004125 Backports:SLE-15-SP5 / deluge
https://build.opensuse.org/request/show/1004126 Backports:SLE-15-SP4 / deluge
https://build.opensuse.org/request/show/1004127 Backports:SLE-15-SP3 / deluge
Comment 4 Swamp Workflow Management 2022-11-06 20:19:41 UTC
openSUSE-SU-2022:10189-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1203162
CVE References: CVE-2021-3427
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP4 (src):    deluge-2.1.1-bp154.2.3.1
Comment 5 Swamp Workflow Management 2022-11-06 20:20:14 UTC
openSUSE-SU-2022:10190-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1203162
CVE References: CVE-2021-3427
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP3 (src):    deluge-2.1.1-bp153.2.3.1