Bug 973996 (CVE-2016-3099)

Summary: VUL-1: CVE-2016-3099: apache2-mod_nss: Invalid handling of +CIPHER operator
Product: [Novell Products] SUSE Security Incidents Reporter: Johannes Segitz <jsegitz>
Component: IncidentsAssignee: Vítězslav Čížek <vcizek>
Status: RESOLVED FIXED QA Contact: Security Team bot <security-team>
Severity: Normal    
Priority: P5 - None CC: meissner, smash_bz, vcizek
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: openSUSE 42.1   
URL: https://smash.suse.de/issue/166181/
Whiteboard: CVSSv2:SUSE:CVE-2016-3099:3.3:(AV:L/AC:M/Au:N/C:P/I:P/A:N) CVSSv2:RedHat:CVE-2016-3099:1.9:(AV:L/AC:M/Au:N/C:N/I:P/A:N)
Found By: Security Response Team Services Priority:
Business Priority: Blocker: ---
Marketing QA Status: --- IT Deployment: ---

Description Johannes Segitz 2016-04-05 07:49:00 UTC
rh#1319052

It was reported that +CIPHER operator in OpenSSL changes the order of a cipher. Since cipher ordering isn't supported in NSS, the mod_nss code was supposed to return an error. Instead it returned the result of processing up to that point. Default OpenSSL cipher string:

!SSLv2:kEECDH:kRSA:kEDH:kPSK:+3DES:!aNULL:!eNULL:!MD5:!EXP:!RC4:!SEED:!IDEA:!DES

Would not properly exclude anything because only the first 5 elements would be examined.

Acknowledgments: Rob Crittenden (Red Hat)

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1319052
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-3099
Comment 1 Vítězslav Čížek 2016-04-05 08:26:16 UTC
Only Factory is affected.
Other distributions have mod_nss 1.0.8, which doesn't support openssl style cipherlist.
(The feature was added in 1.0.11)
Comment 2 Vítězslav Čížek 2016-04-16 10:18:34 UTC
Factory package updated to 1.0.14.
Comment 3 Bernhard Wiedemann 2016-04-19 09:00:12 UTC
This is an autogenerated message for OBS integration:
This bug (973996) was mentioned in
https://build.opensuse.org/request/show/390637 Factory / apache2-mod_nss