Bug 1000929 - failed to set browseallow value @LOCAL in /etc/cups/cupsd.conf
failed to set browseallow value @LOCAL in /etc/cups/cupsd.conf
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: YaST2
Leap 42.3
All SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: Johannes Meixner
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-24 08:00 UTC by Per Jessen
Modified: 2019-07-11 11:06 UTC (History)
2 users (show)

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Per Jessen 2016-09-24 08:00:15 UTC
I was trying to set cups to only accept anouncements from the local network. Apparently using @LOCAL is unsupported as of cups 1.6.
Comment 1 Johannes Meixner 2016-09-26 09:04:30 UTC
Regarding "using @LOCAL is unsupported as of cups 1.6":
This is true (i.e. this is not a bug).

This issue is a duplicate of bug#959801 and
a duplicate of our internal SLES12 bug#970969
 "yast2-printer: accepting printer announcements
  only from local network (@LOCAL) is no longer
  supported since CUPS >= 1.6"
that reads (excerpts):
--------------------------------------------------------------------------
... you have selected
"Accept printer announcement from CUPS server"
with the "General Setting" to
"accept from all host is the local network".

Accepting printer announcements only from the local network (@LOCAL)
is no longer supported since CUPS >= 1.6.

When you click the "Details" button on that "Error" popup
you get some rather technical low-level information
what is no longer supported.

It works (at least for me) when you select
"Accept printer announcement from CUPS server"
with the "General Setting" to
"accept all announcements from anywhere".

Because we also provide traditional CUPS 1.5.4
for SLE12 via the "legacy" module, cf.
https://www.suse.com/releasenotes/x86_64/SUSE-SLES/12/
the YaST printer module in SLE12 works both
for traditional CUPS up to 1.5.4 and also
for newer CUPS >= 1.6

In the end the issue is a usability issue in yast2-printer
that it does not adapt its dialogs according to the actually
installed CUPS version so that only things that actually work
are selectable by the user.
--------------------------------------------------------------------------

Since a long time I do no longer have the time
to actively work on yast2-printer.


Therefore I do no longer maintain yast2-printer for openSUSE:
-------------------------------------------------------------------------
$ osc maintainer yast2-printer
Defined in project:  YaST:Head
  bugowner of yast2-printer : 
   -

  maintainer of yast2-printer : 
   cwh, sh-sh-sh, jdsn, locilka, mvidner, varkoly, lslezak, snwint,
   jreidinger, aschnell, jsrain, mfilka, ancorgs, yast-team,
   IGonzalezSosa, shundhammer, teclator, group:factory-maintainers
-------------------------------------------------------------------------

See also
http://lists.opensuse.org/yast-devel/2015-03/msg00044.html

In the foreseeable future there is nothing what I could do here.

*** This bug has been marked as a duplicate of bug 959801 ***
Comment 2 Johannes Meixner 2016-09-26 09:10:48 UTC
This is no duplicate of bug#959801 because that one
is about printer sharing while this one is about browsing.

But both are similar because both have same root cause:

The backward-incompatible changes in CUPS >= 1.6
that cause some usability issues in yast2-printer
because currently yast2-printer is only provisionally
adapted for CUPS >= 1.6.
Comment 3 Per Jessen 2018-01-31 10:52:00 UTC
As it is not a duplicate and as I have just seen the same issue in Leap42.3, I am reopening this.
Comment 4 Tomáš Chvátal 2019-07-11 11:06:08 UTC
This is automated batch bugzilla cleanup.

The openSUSE 42.3 changed to end-of-life (EOL [1]) status. As such
it is no longer maintained, which means that it will not receive any
further security or bug fix updates.
As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
openSUSE (At this moment openSUSE Leap 15.1, 15.0 and Tumbleweed) please
feel free to reopen this bug against that version (!you must update the
"Version" component in the bug fields, do not just reopen please), or
alternatively create a new ticket.

Thank you for reporting this bug and we are sorry it could not be fixed
during the lifetime of the release.

[1] https://en.opensuse.org/Lifetime