Bug 1002417 - RPM package installation with "Install Software" fails if location contains spaces
RPM package installation with "Install Software" fails if location contains s...
Status: RESOLVED WONTFIX
: 1017696 (view as bug list)
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: YaST2
Leap 42.2
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Ancor Gonzalez Sosa
Jiri Srain
https://trello.com/c/tjc6qVDU
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-01 11:20 UTC by Mindaugas Baranauskas
Modified: 2018-06-01 15:05 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mindaugas Baranauskas 2016-10-01 11:20:10 UTC
Current yast2-packager use 
xdg-su -c "/sbin/yast2 sw_single %F"
command for execution, but will not work with filenames containing space in path or filename. 

See https://features.opensuse.org/319376 and 
https://build.opensuse.org/package/show/home:embar-:Lietukas/yast2-rpm-handler
for solution.
Comment 1 Knut Alejandro Anderssen González 2017-04-03 15:45:43 UTC
*** Bug 1017696 has been marked as a duplicate of this bug. ***
Comment 2 Tomáš Chvátal 2018-04-17 13:41:44 UTC
This is automated batch bugzilla cleanup.

The openSUSE 42.2 changed to end-of-life (EOL [1]) status. As such
it is no longer maintained, which means that it will not receive any
further security or bug fix updates.
As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
openSUSE, or you can still observe it under openSUSE Leap 15.0, please
feel free to reopen this bug against that version (see the "Version"
component in the bug fields), or alternatively open
a new ticket.

Thank you for reporting this bug and we are sorry it could not be fixed
during the lifetime of the release.

[1] https://en.opensuse.org/Lifetime
Comment 3 Ladislav Slezák 2018-06-01 15:05:01 UTC
JFYI: This has been fixed in yast2-packager-4.0.62 in Leap 15.0.