Bug 1003298 - Kernel errors when using spice (QXL) video in KVM
Kernel errors when using spice (QXL) video in KVM
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Takashi Iwai
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-06 09:08 UTC by Martin Kravec
Modified: 2016-10-25 08:34 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
screenshot (51.88 KB, image/png)
2016-10-14 15:34 UTC, Martin Kravec
Details
Fix patch (1.94 KB, patch)
2016-10-20 13:24 UTC, Takashi Iwai
Details | Diff
Revised fix (2.34 KB, patch)
2016-10-20 14:41 UTC, Takashi Iwai
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Kravec 2016-10-06 09:08:52 UTC
I installed TW into KVM with default settings. I used Spice + QXL video.
After installation I switch to tty1 and try to login. After entering username I see error log in console. The same error is repeated when working in console.

Tested: Snapshot-20161004

Error:
 kernel: [TTM] Buffer eviction failed
 kernel: qxl 0000:00:02.0: object_init failed for (4026540032, 0x00000001)
 kernel: [drm:qxl_alloc_bo_reserved [qxl]] *ERROR* failed to allocate VRAM BO
Comment 1 Martin Kravec 2016-10-14 15:34:28 UTC
Created attachment 697452 [details]
screenshot

Just to describe how annoying is this issue.
Comment 2 Takashi Iwai 2016-10-19 15:25:22 UTC
This looks like an upstream regression.  I could reproduce it, too.
Let me check the changes...
Comment 3 Takashi Iwai 2016-10-19 15:53:16 UTC
OK, I could bisect it.  It's the deferred_io support in qxl driver:
6819c3c2517604f979da3de773f2420e07dd4f4b
    drm/qxl: Use drm_fb_helper deferred_io support
Comment 4 Takashi Iwai 2016-10-19 15:57:21 UTC
Reported in upstream
  https://bugs.freedesktop.org/show_bug.cgi?id=98322

Let's track there.
Comment 5 Takashi Iwai 2016-10-20 13:24:29 UTC
I submitted the fix patch to upstream.  Attached below.
Comment 6 Takashi Iwai 2016-10-20 13:24:51 UTC
Created attachment 698370 [details]
Fix patch
Comment 7 Takashi Iwai 2016-10-20 14:41:06 UTC
Created attachment 698380 [details]
Revised fix
Comment 8 Takashi Iwai 2016-10-25 08:34:41 UTC
The revised fix patch was pushed to master and stable branch.