Bug 1013918 - wicked takes extremely long during system start
wicked takes extremely long during system start
Status: RESOLVED DUPLICATE of bug 972471
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Network
Leap 42.2
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: wicked maintainers
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-06 12:08 UTC by Axel Braun
Modified: 2018-02-17 04:46 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
systemd-analyze plot > result.svg (155.65 KB, image/svg+xml)
2016-12-15 09:27 UTC, Axel Braun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Braun 2016-12-06 12:08:12 UTC
The computer is a desktop with a fix eth0 connection and a new 42.2 installation
southpole:/home/axel # systemd-analyze blame
         18.500s wicked.service
          1.006s systemd-journal-flush.service
           988ms apparmor.service
           811ms display-manager.service
           538ms var-tmp.mount

I had tried already to change the eth0 connection to 'when hotplugged' and others, but no change.
I found as well https://bugzilla.opensuse.org/show_bug.cgi?id=972471 but this relates to 42.1 only. Seems the problem is back in 42.2?

Informationen zu Paket wicked:
------------------------------
Repository         : openSUSE-Leap-42.2-Oss              
Name               : wicked                              
Version            : 0.6.38-2.1
Comment 1 Axel Braun 2016-12-15 09:23:56 UTC
Latest update of wicked did not solve issue:
# rpm -qa | grep wicked
libwicked-0-6-0.6.39-4.1.x86_64
wicked-service-0.6.39-4.1.x86_64
wicked-0.6.39-4.1.x86_64
Comment 2 Axel Braun 2016-12-15 09:27:41 UTC
Created attachment 706568 [details]
systemd-analyze plot > result.svg
Comment 3 Per Jessen 2017-01-28 09:19:20 UTC
I am seeing the same, desktop system with fixed eth0 connection. "systemd-analyze blame" reports 20 second start time for wicked.service.
Comment 4 Karl Cheng 2018-02-17 04:46:48 UTC
Looks like the same issue as bug 972471.

If you can still reproduce this with a current version of openSUSE, please file a new bug or reopen this one. Thank you!

*** This bug has been marked as a duplicate of bug 972471 ***