Bug 1019634 - [Build 20170111] repo on USB medium is not disabled for "hd:///…scsi…usbstick", only for "hd:///…usb-"
[Build 20170111] repo on USB medium is not disabled for "hd:///…scsi…usbstick...
Status: NEW
: 1029018 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Ladislav Slezák
Jiri Srain
http://openqa.opensuse.org/tests/3330...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-12 15:48 UTC by Oliver Kurz
Modified: 2017-03-13 19:18 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurz 2017-01-12 15:48:07 UTC
## Observation

As described in bug 1012258 as well as bug 793709 a USB thumbdrive should be disabled as install repo after the installation as the USB thumbdrive is likely to be removed.

it looks like for Leap it behaves like SLE https://openqa.opensuse.org/tests/332434#step/zypper_lr/5 so is disabled but for TW it is called "scsi" and therefore not disabled. bug in the repo detection?

openQA on Tumbleweed shows this: 
http://openqa.opensuse.org/tests/333026/modules/zypper_lr/steps/5


## Reproducible

Always on Tumbleweed, SLE 12 SP3 behaved like this up to build 0059 (https://bugzilla.suse.com/show_bug.cgi?id=1012258#c8) but now SLE behaves like it should, same for Leap


## Expected result

https://openqa.opensuse.org/tests/332434#step/zypper_lr/5


## Further details

Always latest result in this scenario: [latest](http://openqa.opensuse.org/tests/latest?version=Tumbleweed&test=kde&distri=opensuse&flavor=DVD&machine=USBboot_64&arch=x86_64)
Comment 1 Steffen Winterfeldt 2017-01-12 16:05:22 UTC
Nothing I can do here; see discussion in bug 1012258.

Ladislav, assigning to you for now; feel free to pass it on to yast-internal if it's nothing for you.
Comment 2 Oliver Kurz 2017-01-12 16:36:18 UTC
FYI: The proposal from https://bugzilla.suse.com/show_bug.cgi?id=1012258#c11 is to check /sys/block/XXX/removable maybe additionally of what yast did in https://github.com/yast/yast-packager/pull/193
Comment 3 Oliver Kurz 2017-01-12 16:43:21 UTC
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2306 adds a "record_soft_failure" referencing this bug now.
Comment 4 Knut Alejandro Anderssen González 2017-03-13 19:18:23 UTC
*** Bug 1029018 has been marked as a duplicate of this bug. ***