Bug 1023774 - Please no longer write KEYMAP in /etc/vconsole.conf directly
Please no longer write KEYMAP in /etc/vconsole.conf directly
Status: RESOLVED FIXED
: 1031925 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P2 - High : Major (vote)
: ---
Assigned To: Gilson Souza
Jiri Srain
https://trello.com/c/APJlKJUa/1444-sl...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-06 13:36 UTC by Stefan Dirsch
Modified: 2017-06-20 14:17 UTC (History)
7 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Dirsch 2017-02-06 13:36:26 UTC
KEYMAP in /etc/vconsole.conf should no longer be written directly by YaST. Instead please run 

  1) localectl set-x11-keymap us (*)
  2) localectl set-keymap <KEYMAP> [OPTIONS]

I just removed the script, which tried to set these keymaps according to the value in /etc/vconsole.conf during displaymanger startup. Unfortunately this  didn't work reliably, if this file is written not by localectl itself. LOL. See bnc#1023211 for more funny details.

(*) 1) is currently needed due to a different bug. X11 keymap is not written
       when using set-keymap option, if there is no X11 keymap snippet yet.
       I'll open an additional bug for this.
Comment 1 Josef Reidinger 2017-02-08 08:18:29 UTC
ancor as you touch this area, can you please check it? thanks
Comment 2 Ancor Gonzalez Sosa 2017-02-08 15:48:41 UTC
I'll try to take care next week.

I wish we could find a volunteer for this GSoC project https://github.com/openSUSE/mentoring/issues/79 ;-)
Comment 3 Stefan Dirsch 2017-03-06 14:34:27 UTC
Ancor, any results you can share with us? Seems Fabian today stumbled across this one today. :-(
Comment 4 Fabian Vogt 2017-03-06 14:39:52 UTC
(In reply to Stefan Dirsch from comment #3)
> Ancor, any results you can share with us? Seems Fabian today stumbled across
> this one today. :-(

This was luckily a different issue, no files except /etc/sysconfig/* were touched at all.
Comment 5 Stefan Dirsch 2017-04-03 10:28:02 UTC
*** Bug 1031925 has been marked as a duplicate of this bug. ***
Comment 6 Stefan Dirsch 2017-04-03 10:32:33 UTC
Seems we are affected according to the duplicate. I would really appreciate if we could fix this in time for sle13. Setting to major therefore. Ancor, can you prioritize this somehow, please?
Comment 7 Lukas Ocilka 2017-05-05 14:05:55 UTC
No, he can't
I can
Comment 8 Stefan Dirsch 2017-05-05 14:21:40 UTC
Ok. So let's reassign this properly.
Comment 9 Lukas Ocilka 2017-05-05 14:31:43 UTC
Correcting
Comment 10 Dr. Werner Fink 2017-05-07 13:04:04 UTC
This locks fate#318426
Comment 11 Gilson Souza 2017-06-20 13:07:23 UTC
The issue is solved in PR https://github.com/yast/yast-country/pull/125, which is already merged into master (TW and SLE15).
Comment 12 Stefan Dirsch 2017-06-20 14:17:02 UTC
Thanks a lot!