Bug 1032865 - Tumbleweed doesn't use keyboard layout from installation routine
Tumbleweed doesn't use keyboard layout from installation routine
Status: RESOLVED DUPLICATE of bug 1046436
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-07 09:52 UTC by P. Otato
Modified: 2017-07-19 13:19 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
output of cat /etc/sysconfig/keyboard (2.91 KB, text/plain)
2017-07-12 12:09 UTC, P. Otato
Details
y2log (958.61 KB, application/x-xz)
2017-07-12 12:13 UTC, P. Otato
Details

Note You need to log in before you can comment on or make changes to this bug.
Description P. Otato 2017-04-07 09:52:44 UTC
When installing Tumbleweed I get to choose a keyboard layout. During installation it's all fine and the choice is respected. But after finishing the installation and rebooting into the chosen desktop environment (Plasma 5) the keyboard layout is reverted to the standard English layout.

Reproducible: always
Comment 1 Stefan Hundhammer 2017-04-18 09:27:40 UTC
Please check if any KDE settings are interfering (possibly with old settings from an existing home directory?). There may be a keyboard layout switcher in the system tray (usually bottom right).

Please try to log in at a text console (Ctrl-Alt-F2; back with Ctrl-Alt-F7). Is the keyboard layout there also wrong?

Is the entry in /etc/sysconfig/keyboard also wrong? If yes, please attach that file.

If all that doesn't help, please attach y2logs (use save_y2logs).
Comment 2 Stefan Hundhammer 2017-05-03 16:29:17 UTC
Any news on this? It's been 4 weeks.
Comment 3 Stefan Hundhammer 2017-05-18 11:54:24 UTC
No response.
Comment 4 P. Otato 2017-07-12 12:09:04 UTC
Created attachment 732097 [details]
output of cat /etc/sysconfig/keyboard

(In reply to Stefan Hundhammer from comment #1)
> Please check if any KDE settings are interfering (possibly with old settings
> from an existing home directory?). There may be a keyboard layout switcher
> in the system tray (usually bottom right).
> 
> Please try to log in at a text console (Ctrl-Alt-F2; back with Ctrl-Alt-F7).
> Is the keyboard layout there also wrong?
> 
> Is the entry in /etc/sysconfig/keyboard also wrong? If yes, please attach
> that file.
> 
> If all that doesn't help, please attach y2logs (use save_y2logs).

The problem still persists.
- I've tested this with a fresh Tumbleweed install and everything was formatted. So there are no older config files that interfere with the current install. 
- There is also no layout switcher in the system tray.
- TTY keyboard layout is also wrong
- I've attached the output of /etc/sysconfig/keyboard. The only set entry regarding the layout is YAST_KEYBOARD="german,pc104"
- the output of "setxkbmap -query" is "layout: us"
- I will also attached the y2logs
Comment 5 P. Otato 2017-07-12 12:13:58 UTC
Created attachment 732100 [details]
y2log
Comment 6 P. Otato 2017-07-12 12:14:41 UTC
Reopened, because bug does still occur.
Comment 7 Kazufumi Watanabe 2017-07-18 04:13:07 UTC
Dear P.Otato

I think similar this bug.
https://bugzilla.suse.com/show_bug.cgi?id=1046436
Comment 8 Steffen Winterfeldt 2017-07-19 13:19:10 UTC
Yes, a duplicate. Thanks, Kazufumi!

*** This bug has been marked as a duplicate of bug 1046436 ***