Bug 1033150 - (CVE-2016-1517) VUL-0: CVE-2016-1517: opencv: denial of service (segfault) via vectors involving corrupt chunks
(CVE-2016-1517)
VUL-0: CVE-2016-1517: opencv: denial of service (segfault) via vectors involv...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 42.3
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Security Team bot
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-10 07:59 UTC by Alexander Bergmann
Modified: 2018-06-11 16:12 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bergmann 2017-04-10 07:59:39 UTC
CVE-2016-1517

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via
vectors involving corrupt chunks.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-1517
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-1517
Comment 2 Alexander Bergmann 2018-04-13 15:52:15 UTC
Move this bug to openSUSE Leap 42.3.
Comment 3 Swamp Workflow Management 2018-04-28 01:30:05 UTC
This is an autogenerated message for OBS integration:
This bug (1033150) was mentioned in
https://build.opensuse.org/request/show/602155 42.3 / opencv
Comment 4 Swamp Workflow Management 2018-05-04 15:20:05 UTC
This is an autogenerated message for OBS integration:
This bug (1033150) was mentioned in
https://build.opensuse.org/request/show/604051 42.3+Backports:SLE-12-SP3 / opencv
Comment 5 Andreas Stieger 2018-05-04 16:28:59 UTC
Wolfgang asked:
> Is this fixed in 3.1.1 that is in KDE:Extra and Tumbleweed, or should it be
> applied there too?

https://github.com/opencv/opencv/commit/999f41fb4f4aa94a0cb47256919ae8b5c29ca5f3

This seems to be present in 3.1.1.
Comment 6 Swamp Workflow Management 2018-05-11 22:32:06 UTC
openSUSE-SU-2018:1265-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1033150,1033152
CVE References: CVE-2016-1516,CVE-2016-1517
Sources used:
openSUSE Leap 42.3 (src):    opencv-3.1.0-4.3.1, opencv-qt5-3.1.0-4.3.1
Comment 7 Swamp Workflow Management 2018-05-11 22:35:35 UTC
openSUSE-SU-2018:1271-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1033150,1033152
CVE References: CVE-2016-1516,CVE-2016-1517
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    opencv-3.1.0-5.1, opencv-qt5-3.1.0-5.1
Comment 8 Qiang Zheng 2018-05-16 03:33:37 UTC
*** Bug 1052451 has been marked as a duplicate of this bug. ***
Comment 9 Marcus Meissner 2018-06-11 16:12:13 UTC
released