Bug 1042812 - (CVE-2017-9440) VUL-0: CVE-2017-9440: ImageMagick: In ImageMagick 7.0.5-5, a memory leak was found in the function ReadPSDChannelin coders/psd.c
(CVE-2017-9440)
VUL-0: CVE-2017-9440: ImageMagick: In ImageMagick 7.0.5-5, a memory leak was ...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/186274/
CVSSv2:SUSE:CVE-2017-9440:4.3:(AV:N/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 06:23 UTC by Victor Pereira
Modified: 2017-08-28 14:59 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Pereira 2017-06-06 06:23:11 UTC
CVE-2017-9440

In ImageMagick 7.0.5-5, a memory leak was found in the function ReadPSDChannel
in coders/psd.c, which allows attackers to cause a denial of service via a
crafted file.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-9440
http://www.cvedetails.com/cve/CVE-2017-9440/
https://github.com/ImageMagick/ImageMagick/issues/462
Comment 1 Petr Gajdos 2017-06-28 09:32:54 UTC
I am not able to reproduce nowhere with valgrind --leak-check=full.

12/ImageMagick seem to be affected. 

11/ImageMagick and GraphicsMagick does not support PSD Compression, thus not affected.
Comment 2 Petr Gajdos 2017-06-30 16:53:16 UTC
Packages submitted in case someone would like to continue with the rest of bugs during my vacation.
Comment 5 Swamp Workflow Management 2017-08-17 10:09:27 UTC
SUSE-SU-2017:2199-1: An update that fixes four vulnerabilities is now available.

Category: security (important)
Bug References: 1042812,1042826,1043289,1049072
CVE References: CVE-2017-11403,CVE-2017-9439,CVE-2017-9440,CVE-2017-9501
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP3 (src):    ImageMagick-6.8.8.1-71.5.3
SUSE Linux Enterprise Workstation Extension 12-SP2 (src):    ImageMagick-6.8.8.1-71.5.3
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    ImageMagick-6.8.8.1-71.5.3
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    ImageMagick-6.8.8.1-71.5.3
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    ImageMagick-6.8.8.1-71.5.3
SUSE Linux Enterprise Server 12-SP3 (src):    ImageMagick-6.8.8.1-71.5.3
SUSE Linux Enterprise Server 12-SP2 (src):    ImageMagick-6.8.8.1-71.5.3
SUSE Linux Enterprise Desktop 12-SP3 (src):    ImageMagick-6.8.8.1-71.5.3
SUSE Linux Enterprise Desktop 12-SP2 (src):    ImageMagick-6.8.8.1-71.5.3
Comment 6 Marcus Meissner 2017-08-25 12:45:32 UTC
released
Comment 7 Swamp Workflow Management 2017-08-28 13:08:17 UTC
openSUSE-SU-2017:2271-1: An update that fixes four vulnerabilities is now available.

Category: security (important)
Bug References: 1042812,1042826,1043289,1049072
CVE References: CVE-2017-11403,CVE-2017-9439,CVE-2017-9440,CVE-2017-9501
Sources used:
openSUSE Leap 42.3 (src):    ImageMagick-6.8.8.1-34.1
openSUSE Leap 42.2 (src):    ImageMagick-6.8.8.1-30.6.1