Bug 1045880 - Keyboard layout defaults to US
Keyboard layout defaults to US
Status: RESOLVED DUPLICATE of bug 1046436
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-24 19:46 UTC by Ivan Tomica
Modified: 2017-07-05 13:56 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Tomica 2017-06-24 19:46:53 UTC
After initial installation of OpenSUSE Tumbleweed, selecting any other keyboard layout than english results in using US layout after booting into installed system.

Yast shows keyboard layout that was selected but when typing it is clear that this layout is not respected.

Selecting other layout, applying changes then returning back to Yast and selecting preferred layout and applying works as a workaround of this issue.
Comment 1 Michal Filka 2017-06-28 07:36:08 UTC
It is not clear to me if you changed the layout during the installation and the installed system uses the wrong one or if you work just in the fresh system.

Could you pls clarify that?
What is version of yast2-country?
Comment 2 Ivan Tomica 2017-06-28 08:59:40 UTC
During the installation I've selected Croatian (hr/croat) layout but after the installation, yast shows up Croatian while it is in fact using English as a layout.

This could potentially be related to the desktop environment not respecting the layout. KDE is DE that's used and issue can also be resolved by simply changing layout in KDE settings.

Package version: yast2-country-3.2.12-1.1.x86_64
Comment 3 Steffen Winterfeldt 2017-07-05 13:56:52 UTC
looks like a dup of bug 1046436

*** This bug has been marked as a duplicate of bug 1046436 ***