Bug 1046967 - Wrong keyboard map for LUKS encryption password
Wrong keyboard map for LUKS encryption password
Status: RESOLVED DUPLICATE of bug 1046436
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/FLpKefYV
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-02 15:54 UTC by the ghost
Modified: 2017-07-06 09:57 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description the ghost 2017-07-02 15:54:47 UTC
Hi,
today I tried a fresh installation of tumbleweed.
I used to use the recommended partition layout for with encrypted lvm.

There I hit an error, when using a non us locale.
This error is seems hard as other installers are hit by it too (e.g. Calamares). Maybe you can forge a good test-case for openqa of it after fixing it.

Steps to reproduce:

1. Boot into live installer
2. Select a non-us-locale and language (in my case "de_de").
3. Select recommended partition layout for encryption
4. Type in your encryption password and use special characters (which are mapped to other keys on the us keyboard, like "ΓΆ,:!..."
5. Finish installation and try to enter your new password.

Actual result:

You retype your password of step 4 and you got an error about incorrect passphrase.

Expected result:

You retype your password of step 4 and your password is accepted.


The installer has to take care that the encryption password respects the locale which is used by default after installation (most probably us locale). Or the installer has to set another non-us locale as default at install for cryptsetup.

If you need a way to look how other installer are doing it right, look at Anaconda. Last time I checked I worked flawlessly.
Comment 1 Stefan Hundhammer 2017-07-03 10:23:37 UTC
I am pretty sure this is not about the locale, but about the keyboard mapping.

I am also sure that it's not about the installer using the correct key map (German in your case), but about the bootloader or the boot process not using it (very likely falling back to the default en_US).
Comment 2 Andreas Stieger 2017-07-04 07:53:08 UTC
That is correct. LUKS in dracut does not support keyboard layouts.
Also note that if this should be added in dracut, it would also need to be supported in grub's support for LUKS.
Comment 3 Steffen Winterfeldt 2017-07-06 09:57:38 UTC
this is very likely a duplicate of bug 1046436

*** This bug has been marked as a duplicate of bug 1046436 ***