Bug 1064783 - (CVE-2016-10516) VUL-1: CVE-2016-10516: python-Werkzeug: XSS in the render_full function in debug/tbtools.py
(CVE-2016-10516)
VUL-1: CVE-2016-10516: python-Werkzeug: XSS in the render_full function in de...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/194014/
CVSSv2:SUSE:CVE-2016-10516:4.0:(AV:N...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-24 06:08 UTC by Johannes Segitz
Modified: 2020-06-17 18:03 UTC (History)
4 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Segitz 2017-10-24 06:08:34 UTC
CVE-2016-10516

Cross-site scripting (XSS) vulnerability in the render_full function in
debug/tbtools.py in the debugger in Pallets Werkzeug before 0.11.11 (as used in
Pallets Flask and other products) allows remote attackers to inject arbitrary
web script or HTML via a field that contains an exception message.

SUSE:SLE-12:Update and NON_Public:infrastructure

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-10516
https://github.com/pallets/werkzeug/pull/1001
http://blog.neargle.com/2016/09/21/flask-src-review-get-a-xss-from-debuger/
Comment 1 Keith Berger 2020-06-09 18:47:15 UTC
SOC9 uses 0.14.1 https://build.suse.de/package/show/SUSE:SLE-12-SP4:Update:Products:Cloud9/python-Werkzeug

SOC8 uses 0.12.2 https://build.suse.de/package/show/SUSE:SLE-12-SP3:Update:Products:Cloud8/python-Werkzeug

all of these are newer than 0.11.11

Security please close as this does not effect SOC
Comment 2 Marcus Meissner 2020-06-17 18:03:07 UTC
SOC 7 uses older python-Werkzeug 0.9.6, but the rest is fixed.