Bug 1082799 - (CVE-2018-7226) VUL-0: CVE-2018-7226: LibVNCServer: An issue was discovered in vcSetXCutTextProc() in VNConsole.c in LinuxVNC andVNCommand from the LibVNC/vncterm distribution through 0.9.10. Missingsanitization of the client-specified message length may
(CVE-2018-7226)
VUL-0: CVE-2018-7226: LibVNCServer: An issue was discovered in vcSetXCutTextP...
Status: RESOLVED INVALID
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P5 - None : Normal
: ---
Assigned To: Petr Gajdos
Security Team bot
https://smash.suse.de/issue/200429/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-26 10:17 UTC by Karol Babioch
Modified: 2018-02-26 10:19 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Babioch 2018-02-26 10:17:33 UTC
CVE-2018-7226

An issue was discovered in vcSetXCutTextProc() in VNConsole.c in LinuxVNC and
VNCommand from the LibVNC/vncterm distribution through 0.9.10. Missing
sanitization of the client-specified message length may cause integer overflow
or possibly have unspecified other impact via a specially crafted VNC packet.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-7226
http://seclists.org/oss-sec/2018/q1/166
http://people.canonical.com/~ubuntu-security/cve/2018/CVE-2018-7226.html
http://www.cvedetails.com/cve/CVE-2018-7226/
http://openwall.com/lists/oss-security/2018/02/18/2
https://github.com/LibVNC/vncterm/issues/6
Comment 1 Karol Babioch 2018-02-26 10:19:06 UTC
Our versions of LibVNCServer do contain the affected code, but we do not package/ship vncterm from LibVNCServer.