Bug 1086546 - Missing dependency for remmina (1.2.0~rcgit.27-1.1)
Missing dependency for remmina (1.2.0~rcgit.27-1.1)
Status: RESOLVED DUPLICATE of bug 1085416
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 Applications
Current
x86-64 openSUSE 42.3
: P5 - None : Normal (vote)
: ---
Assigned To: Felix Zhang
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-22 19:25 UTC by OpenSUSE User
Modified: 2018-05-23 10:01 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description OpenSUSE User 2018-03-22 19:25:54 UTC
In an attempt to fix the issue with FreeRDP (and thus Remmina) and Windows that arose recently, I added the openSUSE Tumbleweed repository in order to install the update with the patch (https://build.opensuse.org/package/view_file/openSUSE:Factory/freerdp/no_connection_to_windows_10_17101.patch).

Doing this necessitated updates to Remmina and other applications and libraries, which I accepted. However, starting Remmina via the GUI shows nothing. Starting remmina from the command line reports this error:

~> remmina
remmina: symbol lookup error: remmina: undefined symbol: gtk_menu_popup_at_pointer
~>

An error like this typically means that the package didn't indicate all of its necessary dependencies, though I haven't determined which dependency Remmina needs to supply this symbol.
Comment 1 Johannes Weberhofer 2018-05-23 10:01:19 UTC
You should not add the tumbleweed repo to get a new version but the development repository for your distribution: https://download.opensuse.org/repositories/X11:/RemoteDesktop/openSUSE_Leap_42.3/

in the meantime this bug has been fixed in the regular 42.3 update process, too ( see #1085416).

*** This bug has been marked as a duplicate of bug 1085416 ***