Bug 1094834 - Unable to install leap 15 on Lenovo T430 along with Windows 10 in dual boot
Unable to install leap 15 on Lenovo T430 along with Windows 10 in dual boot
Status: RESOLVED FIXED
: 1095652 (view as bug list)
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Installation
Leap 15.0
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-28 08:40 UTC by Rashmi Ranjan Mohanty
Modified: 2021-02-13 14:15 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Screenshot of hung install (2.80 MB, image/jpeg)
2018-05-28 08:40 UTC, Rashmi Ranjan Mohanty
Details
hwinfo output (146.30 KB, application/x-bzip)
2018-05-29 14:50 UTC, Rashmi Ranjan Mohanty
Details
Supportconfig logs (4.42 MB, application/x-bzip-compressed-tar)
2018-05-29 14:51 UTC, Rashmi Ranjan Mohanty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rashmi Ranjan Mohanty 2018-05-28 08:40:02 UTC
Created attachment 771520 [details]
Screenshot of hung install

I am unable to install openSUSE Leap 15.0 on my Lenovo T430 laptop. It already has Windows 10 installed. I am trying to install Leap 15 as dual OS. It just gets stuck on the progress bar screen (After loading Kernel and before installer UI comes up). Attaching screenshot. System does not hang though. System responds to Ctrl+Alt+Delete fine and reboots.

Additional information : 
1. On the same laptop Windows 7 and OpenSUSE leap 42.3 were running fine in dual boot mode before formatting the whole system.
2. I tried DVD and NET media for Leap 15 and it gets stuck at same place.
3. Even tried installing Leap 42.3. That also got stuck in the progress screen.
4. Then I tried installing Fedora 27 and it installed fine.

I know since the media is already released there may not be much that can be done to fix the issue in media, but if any workaround can be provided so that I can install Leap 15 on the system, I will be more than happy.
Comment 1 Stefan Hundhammer 2018-05-28 09:24:53 UTC
Not CRITICAL since this does not appear to affect a large number of users. Downgrading serverity accordingly.
Comment 2 Stefan Hundhammer 2018-05-28 09:29:00 UTC
From just that screenshot it is impossible to tell what exactly hangs. It might be during hardware probing; the usual "safe mode" and ACPI parameters to start the installation media come to mind. Also, please make sure the checksums of your media (SHA256SUM / MD5SUM) are correct; this is a common problem.

In general, Lenovo T4xx laptops are known to work well with Linux; they have unproblematic hardware (Intel chipset / Intel graphics), and lots of Linux developers use them. It is somewhat surprising to hear that this kind of laptop causes problems during hardware probing.
Comment 3 Stefan Hundhammer 2018-05-28 09:34:13 UTC
Please check out https://en.opensuse.org/SDB:Installation_help for the ACPI etc. parameters and try again with different settings.
Comment 4 Steffen Winterfeldt 2018-05-28 09:39:54 UTC
For a start try boot option 'plymouth=0'. This at least would reveal where
it hangs. If this does not help, add boot option 'nomodeset'.
Comment 5 Rashmi Ranjan Mohanty 2018-05-28 10:29:38 UTC
I did check the sha256sum of the iso I had downloaded before using it. It was matching. So no problem with the iso. I wrote it to USB using SUSE Studio image writer. Hope no issues with that.

The problem is with my home laptop. Once I reach home I will try the boot options and update the bug with the findings.
Comment 6 Rashmi Ranjan Mohanty 2018-05-28 14:40:59 UTC
Tried installation with only plymouth=0
It just gets stuck after these two lines..

Starting udev...ok
Loading basic drivers.. ok

It does not go on to load the installation media.

Then I tried installation with plymouth=0 and nomodeset
Now it went fine and installer screen came up. Now I am able to proceed with installation.

Now I am fine with closing the bug or do you need anything else to find out what was causing the issue ? I will be glad to provide any other info. Thank you.
Comment 7 Steffen Winterfeldt 2018-05-29 07:15:00 UTC
This points to a kernel video driver issue. I'll reassign to the kernel developers.
Comment 8 Takashi Iwai 2018-05-29 07:31:16 UTC
Try to boot with nomodeset option.  This will skip KMS driver, so if it's really a driver issue, the hang should be avoided, at least.
Comment 9 Takashi Iwai 2018-05-29 07:32:19 UTC
Also, another good test would be to try the recovery image, instead of the installation.  You can test it quickly on both Leap 42.3 and 15.0 DVDs.
Comment 10 Steffen Winterfeldt 2018-05-29 07:43:44 UTC
Takashi, see comment 6. nomodeset helps.
Comment 11 Takashi Iwai 2018-05-29 07:58:57 UTC
OK, then it's likely an issue of KMS driver.  But to be sure, confirm the problem with recovery images without nomodeset, too.

The next step would be to continue installation fully with nomodeset, getting the running system, and get hwinfo output (or supportconfig would be best).

Then try to load the KMS driver module manually with modeset=1 module option for the specific module.
Comment 12 Rashmi Ranjan Mohanty 2018-05-29 08:32:02 UTC
(In reply to Takashi Iwai from comment #9)
> Also, another good test would be to try the recovery image, instead of the
> installation.  You can test it quickly on both Leap 42.3 and 15.0 DVDs.

The very first day before raising this bug, I had tried the "Rescue System" in boot menu of the 15.0 DVD without any boot option. It got stuck in the same place. I have not tried "Rescue System" with nomodeset option yesterday. Should I try that ?

Also yesterday I did a full install with nomodeset option. But then the UI in the running desktop was very sluggish. Since the system has NVIDIA card, I installed the proprietary NVIDIA driver. Still the UI is sluggish. No change at all. Could it be because of using the nomodeset option ?
Comment 13 Rashmi Ranjan Mohanty 2018-05-29 08:35:17 UTC
(In reply to Takashi Iwai from comment #11)

> The next step would be to continue installation fully with nomodeset,
> getting the running system, and get hwinfo output (or supportconfig would be
> best).

I will provide this tonight once I go home.

> Then try to load the KMS driver module manually with modeset=1 module option
> for the specific module.

Can you please provide the steps for this or point to documentation ? I am not very familiar with this.
Comment 14 Takashi Iwai 2018-05-29 08:40:44 UTC
OK, then no need for further testing with the rescue image.

But could you give hwinfo output?  The system information is completely missing, so far.

I guess your machine has the hybrid graphics, onboard Intel for modesetting and Nvidia discrete GPU for extra 3D.  The nomodeset option is a full-stop, so both are disabled.  So, even if you install Nvidia, the native graphics won't work unless i915 is enabled.

So, please try to remove nomodeset option.  Since you already installed nvidia binary driver, it should work only with that.

Without the nvidia driver, you may need to disable nouveau driver, i.e. either adding nouveau to the module blacklist or pass nouveau.modeset=0 boot option.
Comment 15 Rashmi Ranjan Mohanty 2018-05-29 10:22:15 UTC
Yes the machine has hybrid graphics card. Intel and Nvidia with nvidia optimus OS detection.

I will provide the hwinfo output in the evening once I reach home since the problem is happening on my home laptop.
Comment 16 Rashmi Ranjan Mohanty 2018-05-29 14:50:13 UTC
Created attachment 771701 [details]
hwinfo output

hwinfo run without any options.
Comment 17 Rashmi Ranjan Mohanty 2018-05-29 14:51:54 UTC
Created attachment 771702 [details]
Supportconfig logs

Ran supportconfig -A command

Supportconfig file checksum
5732a0f1a14b6eb7b695f531ca168add
Comment 18 Rashmi Ranjan Mohanty 2018-05-29 14:56:00 UTC
hwinfo and supportconfig logs are from the laptop I freshly installed Leap 15 with nomodeset option. No Nvidia drivers installed.

While installing in the Boot options screen I had removed nomodeset from the kernel parameters. With that the install went fine, but system failed to boot after installation. I had to force reboot and add nomodeset in the boot option of grub menu. Now I will try nouveau.modeset=0
Comment 19 Rashmi Ranjan Mohanty 2018-05-29 15:16:04 UTC
I added nouveau.modeset=0 to the boot options. Now everything is fine. System boots fine and UI is not sluggish.

With no Nvidia driver and nouveau driver disabled, which driver is being used now ? Also how to I find that out ?
Comment 20 Takashi Iwai 2018-05-29 15:41:53 UTC
Thanks for the information and testing.

Actually there is a known bug in Leap 15.0 GM kernel about nouveau, and that might have hit you.

Could you try the kernel in
  http://download.opensuse.org/repositories/home:/tiwai:/bsc1094751/standard/
?

Try to boot this one without nouveau.modeset=0 option.
Comment 21 Rashmi Ranjan Mohanty 2018-05-29 16:26:25 UTC
(In reply to Takashi Iwai from comment #20)

> Actually there is a known bug in Leap 15.0 GM kernel about nouveau, and that
> might have hit you.
> 
> Could you try the kernel in
>   http://download.opensuse.org/repositories/home:/tiwai:/bsc1094751/standard/
> ?
> Try to boot this one without nouveau.modeset=0 option.

System booted fine with this kernel and without nouveau.modeset=0 option.
Comment 22 Takashi Iwai 2018-05-29 16:30:18 UTC
OK, good to hear.  Then this is the same bug as bug 1094751, the runtime PM problem with nouveau, which appears mostly when running as a discrete GPU (thus it's turned off usually).

The fix is already pushed to my SLE15-UPDATE branch, so it'll be included in the next kernel update.

You can keep using my kernel until the official update comes out.
Comment 23 Takashi Iwai 2018-05-29 18:22:35 UTC
Meanwhile, it'd be probably helpful to put a warning and workaround in release notes for Leap 15.0.

Stefan, could you put the information?

With openSUSE Leap 15.0 GM kernel, nouveau driver may hang up at reboot/shutdown or via the runtime power management.  The bug shall be fixed in the maintenance update kernel, but it may happen during the installation or the first boot.

In that case, as a temporary workaround, boot with nouveau.modeset=1 option.
Once after the update kernel including the fix is installed, remove the option again.
Comment 24 Takashi Iwai 2018-05-29 18:47:08 UTC
(In reply to Takashi Iwai from comment #23)
> With openSUSE Leap 15.0 GM kernel, nouveau driver may hang up at
> reboot/shutdown or via the runtime power management. 

More to be noted, it happens only with a hybrid graphics machine (Intel + Nvidia discrete GPU).
Comment 25 Stefan Knorr 2018-05-30 13:13:29 UTC
Release note added with https://github.com/openSUSE/release-notes-openSUSE/commit/d5a3151
Comment 26 Takashi Iwai 2018-05-30 13:35:33 UTC
BTW, I'm building yet another test kernel including more nouveau backports, which makes it almost equivalent with 4.14.x code.

The test kernel is being built in OBS home:tiwai:leap-15.0-nouveau repo.
It'll appear later at
  http://download.opensuse.org/repositories/home:/tiwai:/leap-15.0-nouveau/standard/

For anyone has a Nvidia graphics machine, it'd be greatly appreciated if you can test with the new kernel and report back whether it works (better) or not.
Comment 27 Rashmi Ranjan Mohanty 2018-05-31 03:27:40 UTC
(In reply to Takashi Iwai from comment #26)

> For anyone has a Nvidia graphics machine, it'd be greatly appreciated if you
> can test with the new kernel and report back whether it works (better) or
> not.

It would be better if you can bump up the release number of the test rpms. After the Leap 15 release one kernel update has been already published. This resulted in two kernel rpms already installed on the system.
kernel-default-4.12.14-lp150.12.4.1.x86_64
kernel-default-4.12.14-lp150.11.4.x86_64

The test rpm has release which is lower than both the above rpms. So after installing the test rpm when system is rebooted, obsolete kernel cleanup module automatically removes the test rpm.
Comment 28 Takashi Iwai 2018-05-31 05:47:36 UTC
Unfortunately, you cannot control the release number freely when you building on OBS.  The release number is determined by OBS checkin.

And yes, it's a known problem for long time.  It hasn't been a big issue on Leap 42.x, so far, just because the kernel version numbers increased via stable updates.  But for Leap 15.0, it won't happen, so this release number problem appears more often.

So, for testing, it's advised to increase the number of kernels you keep by editing /etc/zypp/zypp.conf.  Put more "latest-*" in the multiversion.kernels line.
Comment 29 Takashi Iwai 2018-05-31 07:10:24 UTC
(In reply to Stefan Knorr from comment #25)
> Release note added with
> https://github.com/openSUSE/release-notes-openSUSE/commit/d5a3151

One correction: pass nouveau.modeset=0, not 1.
It's about disabling nouveau KMS.

Also, drm-kmp doesn't exist on Leap 15.0 (and should have been obsoleted via the new kernel package installation), hence the section after that is likely superfluous.
Comment 30 Rashmi Ranjan Mohanty 2018-05-31 14:44:09 UTC
Tried the kernel kernel-default-4.12.14-lp150.7.1.g07517a0.x86_64.rpm without nouveau.modeset=0 . While booting after the splash screen and before GDM login screen there were couple of flickers. After logging in and before the desktop appeared there were couple more flickers. Apart from that everything seems to work fine. 

Graphics performance and animations felt same or bit better compared to kernel kernel-default-4.12.14-lp150.12.4.1.x86_64 with nouveau.modeset=0 . Since this is all about perceptions I am not so sure about this. But its definitely not worse. 

Anything specific I should test ?
Comment 31 Takashi Iwai 2018-05-31 15:24:51 UTC
Thanks, that suffices, just needed to confirm that it doesn't break.

Actually, for the hybrid graphics, the performance won't change at all unless you start applications explicitly with PRIME.
Comment 33 Stelian Ionescu 2018-06-05 23:11:16 UTC
*** Bug 1095652 has been marked as a duplicate of this bug. ***
Comment 34 Swamp Workflow Management 2019-11-26 18:40:34 UTC
This is an autogenerated message for OBS integration:
This bug (1094834) was mentioned in
https://build.opensuse.org/request/show/751120 15.0 / release-notes-openSUSE
Comment 35 Swamp Workflow Management 2019-12-02 08:12:38 UTC
openSUSE-RU-2019:2609-1: An update that has 17 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1085628,1089061,1091103,1092953,1093098,1093398,1093982,1094834,1095111,1095597,1097811,1099004,1102191,1102987,1113694,1125487,1157816
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    release-notes-openSUSE-15.0.20191126-lp150.2.3.1
Comment 36 OBSbugzilla Bot 2021-02-11 17:20:35 UTC
This is an autogenerated message for OBS integration:
This bug (1094834) was mentioned in
https://build.opensuse.org/request/show/871260 15.1 / release-notes-openSUSE
Comment 37 Swamp Workflow Management 2021-02-13 14:15:39 UTC
openSUSE-RU-2021:0282-1: An update that has 15 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1085628,1091103,1092953,1093098,1093398,1094834,1095111,1100005,1116922,1125819,1126496,1129362,1129587,1161841,1182141
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    release-notes-openSUSE-15.1.20210211-lp151.2.3.1