Bug 1095813 - (CVE-2018-10804) VUL-1: CVE-2018-10804: ImageMagick: Memory leak in WriteTIFFImage
(CVE-2018-10804)
VUL-1: CVE-2018-10804: ImageMagick: Memory leak in WriteTIFFImage
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/205366/
CVSSv2:NVD:CVE-2018-10804:4.3:(AV:N/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-04 12:46 UTC by Alexander Bergmann
Modified: 2018-06-30 14:37 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Petr Gajdos 2018-06-14 11:24:43 UTC
No testcase.
Comment 2 Petr Gajdos 2018-06-14 15:07:17 UTC
15/ImageMagick: fix already in
12/ImageMagick: fix required
11/ImageMagick: SetQuantumFormat() return value is not checked and even does
                not return boolean
*/GraphicsMagick: no quantum_info code at all
Comment 3 Petr Gajdos 2018-06-14 15:07:46 UTC
Will submit for 12/ImageMagick.
Comment 4 Petr Gajdos 2018-06-15 12:58:40 UTC
I believe all fixed.
Comment 9 Swamp Workflow Management 2018-06-29 19:09:32 UTC
SUSE-SU-2018:1851-1: An update that fixes 8 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1047356,1056277,1087820,1094204,1094237,1095730,1095812,1095813
CVE References: CVE-2017-10928,CVE-2017-13758,CVE-2017-18271,CVE-2018-10804,CVE-2018-10805,CVE-2018-11251,CVE-2018-11655,CVE-2018-9133
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP3 (src):    ImageMagick-6.8.8.1-71.65.1
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    ImageMagick-6.8.8.1-71.65.1
SUSE Linux Enterprise Server 12-SP3 (src):    ImageMagick-6.8.8.1-71.65.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    ImageMagick-6.8.8.1-71.65.1
Comment 10 Andreas Stieger 2018-06-30 09:45:07 UTC
release for Leap, showing as done
Comment 11 Swamp Workflow Management 2018-06-30 13:10:02 UTC
openSUSE-SU-2018:1860-1: An update that fixes 8 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1047356,1056277,1087820,1094204,1094237,1095730,1095812,1095813
CVE References: CVE-2017-10928,CVE-2017-13758,CVE-2017-18271,CVE-2018-10804,CVE-2018-10805,CVE-2018-11251,CVE-2018-11655,CVE-2018-9133
Sources used:
openSUSE Leap 42.3 (src):    ImageMagick-6.8.8.1-64.1