Bug 1098155 - (CVE-2018-1152) VUL-1: CVE-2018-1152: libjpeg-turbo: libjpeg-turbo 1.5.90 is vulnerable to a denial of service vulnerability causedby a divide by zero when processing a crafted BMP image.
(CVE-2018-1152)
VUL-1: CVE-2018-1152: libjpeg-turbo: libjpeg-turbo 1.5.90 is vulnerable to a ...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/208438/
CVSSv3:SUSE:CVE-2018-1152:3.3:(AV:L/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-19 05:16 UTC by Marcus Meissner
Modified: 2020-04-28 15:41 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Meissner 2018-06-19 05:16:30 UTC
CVE-2018-1152

libjpeg-turbo 1.5.90 is vulnerable to a denial of service vulnerability caused
by a divide by zero when processing a crafted BMP image.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-1152
https://www.tenable.com/security/research/tra-2018-17
https://github.com/libjpeg-turbo/libjpeg-turbo/commit/43e84cff1bb2bd8293066f6ac4eb0df61ddddbc6
Comment 1 Petr Gajdos 2018-06-19 13:23:19 UTC
No testcase found.
Comment 2 Petr Gajdos 2018-06-19 14:11:15 UTC
Submitted for devel/libjpeg-turbo, 15/libjpeg-turbo, 12/libjpeg-turbo, 11/jpeg and 10sp3/jpeg.
Comment 3 Swamp Workflow Management 2018-06-19 14:20:18 UTC
This is an autogenerated message for OBS integration:
This bug (1098155) was mentioned in
https://build.opensuse.org/request/show/617768 Factory / libjpeg-turbo
Comment 5 Swamp Workflow Management 2018-06-20 12:39:17 UTC
An update workflow for this issue was started.
This issue was rated as moderate.
Please submit fixed packages until 2018-07-04.
When done, reassign the bug to security-team@suse.de.
https://swamp.suse.de/webswamp/wf/64067
Comment 6 Swamp Workflow Management 2018-06-27 16:09:32 UTC
SUSE-SU-2018:1825-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1062937,1096209,1098155
CVE References: CVE-2017-15232,CVE-2018-1152,CVE-2018-11813
Sources used:
SUSE Linux Enterprise Software Development Kit 11-SP4 (src):    jpeg-6b-879.12.7.1
SUSE Linux Enterprise Server 11-SP4 (src):    jpeg-6b-879.12.7.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    jpeg-6b-879.12.7.1
Comment 8 Swamp Workflow Management 2019-03-22 19:18:37 UTC
SUSE-SU-2019:0711-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1096209,1098155,1128712
CVE References: CVE-2018-1152,CVE-2018-11813,CVE-2018-14498
Sources used:
SUSE Linux Enterprise Module for Packagehub Subpackages 15 (src):    libjpeg-turbo-1.5.3-5.7.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    libjpeg-turbo-1.5.3-5.7.1, libjpeg62-turbo-1.5.3-5.7.1
SUSE Linux Enterprise Module for Desktop Applications 15 (src):    libjpeg-turbo-1.5.3-5.7.1
SUSE Linux Enterprise Module for Basesystem 15 (src):    libjpeg-turbo-1.5.3-5.7.1, libjpeg62-turbo-1.5.3-5.7.1
Comment 9 Swamp Workflow Management 2019-04-02 16:27:43 UTC
openSUSE-SU-2019:1118-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1096209,1098155,1128712
CVE References: CVE-2018-1152,CVE-2018-11813,CVE-2018-14498
Sources used:
openSUSE Leap 15.0 (src):    libjpeg-turbo-1.5.3-lp150.4.3.2, libjpeg62-turbo-1.5.3-lp150.4.3.2

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2019-04-30 19:13:07 UTC
SUSE-SU-2019:1111-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1096209,1098155,1128712
CVE References: CVE-2018-1152,CVE-2018-11813,CVE-2018-14498
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    libjpeg-turbo-1.5.3-31.14.2, libjpeg62-turbo-1.5.3-31.14.2
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    libjpeg-turbo-1.5.3-31.14.2, libjpeg62-turbo-1.5.3-31.14.2
SUSE Linux Enterprise Server 12-SP4 (src):    libjpeg-turbo-1.5.3-31.14.2, libjpeg62-turbo-1.5.3-31.14.2
SUSE Linux Enterprise Server 12-SP3 (src):    libjpeg-turbo-1.5.3-31.14.2, libjpeg62-turbo-1.5.3-31.14.2
SUSE Linux Enterprise Desktop 12-SP4 (src):    libjpeg-turbo-1.5.3-31.14.2, libjpeg62-turbo-1.5.3-31.14.2
SUSE Linux Enterprise Desktop 12-SP3 (src):    libjpeg-turbo-1.5.3-31.14.2, libjpeg62-turbo-1.5.3-31.14.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2019-05-08 13:12:46 UTC
openSUSE-SU-2019:1343-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1096209,1098155,1128712
CVE References: CVE-2018-1152,CVE-2018-11813,CVE-2018-14498
Sources used:
openSUSE Leap 42.3 (src):    libjpeg-turbo-1.5.3-45.1, libjpeg62-turbo-1.5.3-45.1
Comment 12 Alexandros Toptsoglou 2020-04-28 15:41:40 UTC
Done