Bug 1101281 - (CVE-2018-14055) VUL-0: CVE-2018-14055: ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from thenetwork, allowing a non-admin user to escalate his privilege and inject roguevalues into znc.conf.
(CVE-2018-14055)
VUL-0: CVE-2018-14055: ZNC before 1.7.1-rc1 does not properly validate untrus...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 42.3
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Martin Pluskal
Martin Pluskal
https://smash.suse.de/issue/210682/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-16 06:46 UTC by Karol Babioch
Modified: 2019-03-25 12:10 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Babioch 2018-07-16 06:46:18 UTC
CVE-2018-14055

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the
network, allowing a non-admin user to escalate his privilege and inject rogue
values into znc.conf.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-14055
https://github.com/znc/znc/commit/a7bfbd93812950b7444841431e8e297e62cb524e
https://github.com/znc/znc/commit/d22fef8620cdd87490754f607e7153979731c69d
Comment 2 Swamp Workflow Management 2018-07-16 09:00:10 UTC
This is an autogenerated message for OBS integration:
This bug (1101281) was mentioned in
https://build.opensuse.org/request/show/623072 Factory / znc
https://build.opensuse.org/request/show/623073 15.0+42.3 / znc
Comment 3 Swamp Workflow Management 2018-07-16 10:00:11 UTC
This is an autogenerated message for OBS integration:
This bug (1101281) was mentioned in
https://build.opensuse.org/request/show/623100 Factory / znc
Comment 4 Swamp Workflow Management 2018-07-16 13:20:14 UTC
This is an autogenerated message for OBS integration:
This bug (1101281) was mentioned in
https://build.opensuse.org/request/show/623128 15.0+42.3+Backports:SLE-12-SP2 / znc
Comment 5 Swamp Workflow Management 2018-07-18 08:30:13 UTC
This is an autogenerated message for OBS integration:
This bug (1101281) was mentioned in
https://build.opensuse.org/request/show/623568 15.0+42.3+Backports:SLE-12-SP2 / znc
Comment 6 Swamp Workflow Management 2018-08-07 13:07:54 UTC
openSUSE-SU-2018:2228-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1101280,1101281
CVE References: CVE-2018-14055,CVE-2018-14056
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    znc-1.7.1-2.1
Comment 7 Swamp Workflow Management 2018-08-07 13:09:52 UTC
openSUSE-SU-2018:2231-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1101280,1101281
CVE References: CVE-2018-14055,CVE-2018-14056
Sources used:
openSUSE Leap 42.3 (src):    znc-1.7.1-20.3.1
openSUSE Leap 15.0 (src):    znc-1.7.1-lp150.2.6.1
Comment 8 Marcus Meissner 2018-08-07 13:23:03 UTC
released
Comment 9 Swamp Workflow Management 2019-03-25 12:10:11 UTC
This is an autogenerated message for OBS integration:
This bug (1101281) was mentioned in
https://build.opensuse.org/request/show/688205 15.0+42.3+Backports:SLE-12+Backports:SLE-12-SP2+Backports:SLE-15 / znc