Bug 1104529 - Regression: Linux 4.17 cannot wake from STR after ACPICA: Events: Stop unconditionally clearing ACPI IRQs during suspend/resume
Regression: Linux 4.17 cannot wake from STR after ACPICA: Events: Stop uncond...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
https://patchwork.kernel.org/patch/10...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-10 16:33 UTC by Michal Suchanek
Modified: 2022-07-21 17:24 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
4.12 boot log (64.71 KB, text/plain)
2018-08-10 16:33 UTC, Michal Suchanek
Details
4.17 boot log (66.62 KB, text/plain)
2018-08-10 16:33 UTC, Michal Suchanek
Details
4.16 boot log (66.08 KB, text/plain)
2018-08-13 17:56 UTC, Michal Suchanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Suchanek 2018-08-10 16:33:02 UTC
Created attachment 779472 [details]
4.12 boot log

Between 4.12.11 and 4.17.12-1.4 power button stopped working on STR state.

You can suspend but pressing power button does not wake up system anymore.
Comment 1 Michal Suchanek 2018-08-10 16:33:38 UTC
Created attachment 779473 [details]
4.17 boot log
Comment 2 Michal Suchanek 2018-08-10 16:50:30 UTC
4.14.11 is working
Comment 3 Michal Suchanek 2018-08-10 17:16:37 UTC
4.15.0-2 is working
4.16.13-3 is working
Comment 4 Michal Suchanek 2018-08-13 17:47:27 UTC
4.16.0-1 (1b10c5b) is working
4.17.0-rc2-4 (40ccd10) is broken
4.17.0-3 is broken
4.17.13-1 is broken
4.18.0-1 is broken

that's as far as kotd archives go
Comment 5 Michal Suchanek 2018-08-13 17:56:38 UTC
Created attachment 779619 [details]
4.16 boot log
Comment 6 Takashi Iwai 2018-08-15 10:24:54 UTC
Likely some ACPI changes, maybe about GPE bits, but it's hard to judge which one broke.  The best would be bisection...
Comment 7 Michal Suchanek 2018-08-15 14:45:10 UTC
yes, building a couple testing kernels each day.

Another thing I noticed is the broken kernels immediately wake from STR on first try and stay suspended without any way to wake up on the next.
Comment 8 Michal Suchanek 2018-08-16 15:24:07 UTC
The regression appears to be in v4.16-rc2..4860ae7f58fa ("ACPICA: Update version to 20180313")

If I got the branch right it should be possible to get the exact commit soon.
Comment 9 Jiri Slaby 2018-08-17 06:01:35 UTC
Pushed to master and will merge it from there.

BTW, the original commit message says:
> If this patch triggers regression, the regression should be in the GPE
> handlers that cannot correctly determine some spurious triggered events as
> no-ops. Please report any regression related to this commit to the ACPI
> component on kernel bugzilla. Lv Zheng.

So is this reported?
Comment 10 Michal Suchanek 2018-08-17 13:36:58 UTC
Updated upstream bug URL
Comment 11 Luis Henriques 2018-08-17 15:43:50 UTC
I haven't tested it yet (not a good time for rebooting my laptop), but looks like commit fa85015c0d95 ("ACPICA: Clear status of all events when entering S5"), which is tagged for stable, could fix this issue.  I'll try to test it later (or, more likely, during the weekend).
Comment 12 Takashi Iwai 2018-08-17 16:08:09 UTC
Hrm, Michal has tested 4.18.0, so this should have been included.
It might be not enough for his machine.

Michal, care to double-check?
Comment 13 Luis Henriques 2018-08-17 16:48:25 UTC
Ok, I missed the comment where Michal states that 4.18 is broken.  I've just done a quick test in my laptop with 4.18 and it's working fine.  So we must be hitting a different issue, which for me is already fixed.  Sorry for the noise :-(
Comment 14 Michal Suchanek 2018-08-17 17:15:05 UTC
I think I did not test the 4.18 kernel unpatched. Only that the patch applies and the patched kernel works.
Comment 15 Michal Suchanek 2018-08-17 17:17:23 UTC
oh, right. I tested it way back and it was broken
Comment 16 Michal Suchanek 2018-08-17 18:40:20 UTC
4.18.0-1.g06ab9b3-default is broken
4.18.0-5.g494fb32-default works
Comment 17 Takashi Iwai 2018-08-20 09:31:26 UTC
Could you report this to Rafael, the upstream maintainer?
Comment 18 Michal Suchanek 2018-08-21 14:40:38 UTC
Fixed upstream